[solved] QtCreator cannot find cmake 3.0



  • I have been working fine with QtCreator 3.1.2 and cmake 2.8. Since I updated cmake to the new 3.0.1 version, QtCreator cannot find it any more.

    In Preferences/Build & Run/CMake I set cmake's path:
    /Applications/CMake.app/Contents/MacOS/CMake

    When I select a project to open from QtCreator, I get the CMake wizard, and when clicking on the [Run CMake] button, the process is never completed. I never get the [Done] button active, and I can only [Cancel].

    This happens with both Unix and Ninja generators.

    The dialog I get says: "Failed opening project '/path/to/CMakeLists.txt': Settings could not be restored."

    From the command line, cmake works correctly.

    System: OS X 10.9.4



  • I set the wrong path for cmake, which pointed to the GUI cmake utility. The correct one is:

    /Applications/CMake.app/Contents/bin/cmake


  • Lifetime Qt Champion

    So you got it sorted out ?

    If so, can you also update the thread title prepending [solved] so other forum users my know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.