[Solved] Qt 5.3.1 Error: iOS Simulator failed to install the application ?



  • I have a Qt 5.x QWidget app that previously ran fine in an iOS simulator. Perhaps on QT 5.x before I upgraded to Qt 5.3.1? I do not remember.

    I can run an Apple iOS Xcode sample app just fine in the iOS 7.1 iPad simulator.

    When running a Qt QWidget from Qt Creator I receive:

    @
    Debugging starts
    Session could not be started: Error Domain=DTiPhoneSimulatorErrorDomain Code=1 "iOS Simulator failed to install the application." UserInfo=0x10040ca30 {NSLocalizedDescription=iOS Simulator failed to install the application., DTiPhoneSimulatorUnderlyingErrorCodeKey=-1}Debugging has failed
    Debugging has finished
    @

    I have tried:

    • Deleting the previously installed Qt app from the iOS simulator.
    • Resetting the simulator
    • Deleting contents of ~/Library/Application Support/iPhone Simulator/ folder

    Thanks in a advance for any tips to try,

    -Ed

    Environment:

    • Qt 5.3.1
    • OSX 10.9.4
    • Xcode 5.1.1
    • iOS 7.1


  • [Solved]

    I am not sure why this it works.

    • My iOS app folder is named TSR.app.
    • My app folder contained a Contents/MacOS/ folder ( I build this app for both iOS and OSX)

    The fix was to copy the following two files from the application folder root into the subfolder named /Contents/MacOS as shown in the tree below.

    Info.plist

    PkgInfo

    Here is what my Qt5.2 build directory looked like.
    @
    build-tsr-iphoneos_clang_Qt_5_2_1_for_iOS-Debug
    ├── Debug-iphonesimulator
       └── TSR.app
    ├── Contents
    │   ├── Info.plist
    │   ├── MacOS
    │   └── PkgInfo
    ├── Default-568h@2x.png
    ├── Info.plist
    ├── PkgInfo
    └── TSR
    @


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.