Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[solved] Cannot find compiled addon modules in QT Creator



  • I’m using Qt 5.3.0 for MacOSX and trying to use the QtSystem addon module in my project.

    My Qt 5.3.0 was installed in ~/Qt5 .

    I simply followed this post ( http://qt-project.org/wiki/Building_Qt_5_from_Git ) to compile and install Qt modules into
    folder /usr/local/Qt-5.3.1.

    My question is - how to add this compiled module into my original Qt5 installation ?

    Thanks in advance!


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Clone the repos, call qmake (the one from your original installation) in the root folder, then make and make install, and you should be good to go



  • Hi SGaist,

    Thanks for your assistance.

    I've tried and checkout Qt source into ~/Qt5/qt5 (original installation is in ~/Qt5) , but the build still goes to /usr/local/Qt-5.3.1 not the original one.

    (PS. I use ~/Qt5/5.3/clang_64/qmake to compile the src in ~Qt5/qt5)

    Do I miss any environmental or compile parameters to make it run smoothly?

    Please advice & Thank you very much!



  • I found the build is copy to outbase not my original one.

    <srcbase> = ~/Qt5/5.3/qt5/qtbase
    <outbase> = ~/Qt5/5.3/qt5/qtbase

    Can I simply copy everything from outbase to my original installation?


  • Lifetime Qt Champion

    Are you sure that you used the right qmake ?



  • Sure the ~/Qt5/5.3/Clang_64/bin/qmake is used .....
    After configure it with prefix <original installation>, make, make install....
    Finally, the new module can be found in QT Creator.....
    Thanks for your advice!


  • Lifetime Qt Champion

    You're welcome !

    Since you have your module working now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)


Log in to reply