[SOLVED] Cannot open include file: 'stddef.h': No such file or directory



  • Just downloaded the latest Qt Creator several days ago (3.1.1) and already I can't compile or build anything off of the shelf. My OS is Windows 7 x64

    The error being received is:

    D:\Qt\5.3\msvc2010_opengl\include\QtCore\qglobal.h:46: error: C1083: Cannot open include file: 'stddef.h': No such file or directory

    I've also added this directory to my CLASSPATH and path variables, to no avail. I can also clearly see the file "stddef.h" inside of this directory.

    C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\include

    This error persists when I set the compiler to Visual C++ 12.0, as well as MingW 4.8


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You can't mix Qt versions and compilers like that especially on Windows.

    You must install the Qt version corresponding to the visual studio you have.



  • Okay I'm a little confused then. 2 questions.

    1. Which visual studio version corresponds to Qt 5.3 and Qt Creator 3.1.1?
      I have Visual Studio 2013 Express installed. I figured getting the latest of everything would work.

    2. Why does the visual studio version even matter at all? When I try using the MingW compiler, this error still occurs.

    I did read this: "Qt 5.3 also adds binary packages for Visual Studio 2013." over at
    http://blog.qt.digia.com/blog/2014/05/20/qt-5-3-released/


  • Lifetime Qt Champion

    1. The Qt 5.3 for VS2013 package

    2. Because their compiler are not compatible from version to another and even less with MinGW

    You read right but their's currently packages provided for the last 3 versions of Visual Studio plus MinGW



  • Ah I see now, there is a whole list of available Qt packages. I guess I shouldn't have gone with the Qt online installer.

    So then, this package should work?

    Qt 5.3.0 for Windows 64-bit (VS 2013, OpenGL, 636 MB)



  • Great now it builds and runs fine! Thanks!


  • Lifetime Qt Champion

    Nothing wrong with the online installer, you must just choose your options wisely ;)

    Since you have it working now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.