Problems getting application to run in api level 19 for android



  • I have written an application that runs just fine in all api levels except for level 19. Has anybody had any problems with running their application in kitkat?


  • Moderators

    Any error messages?

    I am running an app at API level 19 without problems (QtQuick 2 application, running on Samsung Galaxy S2).



  • I also have no problems with API level 19 (4.4.2) on my Google Nexus devices it works great!?
    what did you set as minimum and target API level in the Android manifest?



  • I have also no problem, using the Genymotion emulator.



  • Same to me (Win7 Qt 5.2.1). I get

    Unable to start "org.qtproject.example.calqlatr".

    for example for an android emu build.

    Some are working fine, some not. The touch example is working well
    on emu and on device.



  • Hello World tutorial worked, but ...
    Qt Quick Demo - Calqlatr ran but the number key pad went outside of the screen of my Note3 so I ended up with mostly white on the left and a narrow strip of black on the right - no key pad, no calculator. :(



  • I've had similar experiences. When setting the 'Android Target SDK' in the deploy configurations to API level 19 the program crashes on startup with some devices. Switching to API level 10 fixes this. I have not tried any other API levels.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.