Important: Please read the Qt Code of Conduct -

QtPlugin using CUDA Libraries

  • Hi Guys!

    Actually I'm developing a desktop application showing OpenEXR images. OpenEXR is an open HDR format so tone mapping is neccessary to show a rgb picture on screen. Users of the application should be capable to implement their own tone mappers. So I implemented a plugin interface and also use it myself to implement different tone mappers an filter functions. The application is compiled in 64bit.
    One function is using the CUDA-API by Nvidia and is already running fine within another software. The plugin implementation using CUDA is compiling an linking. But QPluginLoader::instance() returns 0 when try loading the plugin with CUDA. When removing CUDA the plugin is loaded. So I guess the plugin interface is implemented correct in the plugin. Has anyone experiences with CUDA (or may be other external libraries) used in QtPlugins???

    I'm thankful for every help!!!


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you check the value of errorString() ?

  • Hi,

    thanks for your try to help me, but I solved it already. I had forgotten to copy the CUDA.dlls into my directory so the plugins couldn't be loaded due to their dependencies to CUDA.


  • Moderators

    Glad you got it solved and that it was an easy fix! Please be sure and edit your first post to prepend [Solved] to the beginning of the title. Thanks!

Log in to reply