OpenGL Window Example crashes



  • I'm trying to build the OpenGL Window Example, this is what I get.
    @Starting C:\Qt\Qt5.2.0\5.2.0\mingw48_32\examples\gui\build-openglwindow-Desktop_Qt_5_2_0_MinGW_32bit-Debug\debug\openglwindow.exe...
    The program has unexpectedly finished.
    C:\Qt\Qt5.2.0\5.2.0\mingw48_32\examples\gui\build-openglwindow-Desktop_Qt_5_2_0_MinGW_32bit-Debug\debug\openglwindow.exe crashed
    @
    Debug says this:
    During startup program exited with code 0xc0000139.
    How to fix?


  • Moderators

    Run in debug mode and see where it crashes.



  • This?
    @23:33:17: Running steps for project openglwindow...
    23:33:17: Configuration unchanged, skipping qmake step.
    23:33:17: Starting: "C:\Qt\Qt5.2.0\Tools\mingw48_32\bin\mingw32-make.exe"
    C:/Qt/Qt5.2.0/Tools/mingw48_32/bin/mingw32-make -f Makefile.Debug
    mingw32-make[1]: Entering directory 'C:/Qt/Qt5.2.0/5.2.0/mingw48_32/examples/gui/build-openglwindow-Desktop_Qt_5_2_0_MinGW_32bit-Debug'
    mingw32-make[1]: Nothing to be done for 'first'.
    mingw32-make[1]: Leaving directory 'C:/Qt/Qt5.2.0/5.2.0/mingw48_32/examples/gui/build-openglwindow-Desktop_Qt_5_2_0_MinGW_32bit-Debug'
    23:33:18: The process "C:\Qt\Qt5.2.0\Tools\mingw48_32\bin\mingw32-make.exe" exited normally.
    23:33:18: Elapsed time: 00:01.@


  • Lifetime Qt Champion

    Hi,

    No that's the compilation output, run your program by clicking on the green arrow with a little bug on it.



  • All I get is this.
    During startup program exited with code 0xc0000139.

    Debugging starts
    Debugging has finished


  • Moderators

    You do have OpenGL drivers installed on your machine, right?

    Try cleaning and rebuilding.



  • Yes, I have drivers. I tried uninstalling Qt and installing it again, didn't help. Anything more I can try?



  • I just noticed that none of the examples work. Same error code. Is is mingw that doesn't work?



  • I searched a bit and found a program called dependency walker, tried it and it said qt5cored.dll and qt5guid.dll is mission amongst others. I couldn't find them in the qt folder, only the same files without the d. Is there a way to fix this and what is it that I have done wrong?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.