Project ERROR: Could not resolve SDK path for 'macosx10.8'



  • Me again,

    Trying to build the same gettingStartedQml C++ folder (file dialog) but on a different mac computer. I follow the instruction in the tutorial using
    @qmake@

    This time I know I'm using the right qmake (5.2.1). I see the terminal thinking for a few seconds and get the error message
    @Project ERROR: Could not resolve SDK path for 'macosx10.8'@

    Any help please

    Thanks

    Bidochon


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Are you sure this Mac has Xcode setup properly ? And the command line tools ?



  • I'm pretty confident it does. I don't have access to this computer right now but I will definitively check that to be sure. I will let you know.

    thanks for the Reply

    Bidochon



  • Hi ,

    I used to get the same error message as the thread opener:
    Project ERROR: Could not resolve SDK path for 'macosx10.8'

    My environment is nearly identical to his : MacOS X 10.9
    Qt 5.3.2 (Problem occurs since I upgraded from 5.3.1 to 5.3.2 and upgraded to Xcode 6.0.1 the same time.)

    After working through some forum threads I tried to solve the problem by changing the qmake.conf which in my case is stored in /Applications/Qt5/5.3/clang_64/mkspecs/macx-clang/qmake.conf
    to configure
    QMAKE_MACOSX_DEPLOYMENT_TARGET = 10.9 instead of 10.6
    what resulted in the clang command line now containing the option -mmacosx-version-min=10.9
    the part yet unsolved is how do I change the sysroot ( current error message:
    clang: warning: no such sysroot directory: '/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.8.sdk)

    ,that does not exist on there as clang indicates , into
    /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk in which my updated Xcode resides.

    adding export QMAKE_MAC_SDK=macosx10.9 did not do the trick

    any ideas how to continue ? (changing the 8 to a 9 manually in the Makefile renders cumbersome over time ...)

    best regards
    Steve



  • The problem was solved - browsing the postings to the mailing list the last hours I found one with a link to this page:

    http://stackoverflow.com/questions/25940368/qt5-target-conditionals-not-found

    changing the qdevice.pri file to MacOS10.9 fixes the problems
    ( in the same step it eliminates problems with dylib image not found for all frameworks )

    regards
    Steve


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.