Compilation for Symbian device using QT 1.1 sdk tech preview



  • Hi,

    I installed qt1.1 sdk tech preview , and I am trying to compile a sample app using Location APIs of QT Mobility . I could get it compiled for Simulator but if I compile for symbian device it gives following error

    Any suggestions will be a great help ...

    Thanks
    Anu


    Recipe link andpostlink failed with exit code 1

    :-1: Running command: C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/tools/checklib.exe stdc++ --elf C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/udeb/qtmain.lib
    Running command: C:/QtSDK/Symbian/tools/gcce4/bin/arm-none-symbianelf-g++.exe -Wl,-Ttext,0x8000 -Wl,--no-undefined -nodefaultlibs -Wl,-shared -Wl,-Tdata,0x400000 -Wl,--default-symver '-Wl,-soname=QWhoWhere{00010100}[eef9ca30].exe' -Wl,--entry=_E32Startup -Wl,-u,_E32Startup,C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/udeb/eexe.lib -o C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/udeb/QWhoWhere.exe.sym -Wl,-Map=C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/udeb/QWhoWhere.exe.map @C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/build/qwhowhere/c_3806921b9e44c3f7/qwhowhere_exe/armv5/udeb/QWhoWhere_udeb_objects.via --start-group C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/udeb/usrt3_1.lib --end-group C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/udeb/usrt3_1.lib C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/udeb/qtmain.lib C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/cone.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/eikcore.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/avkon.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/QtBearer.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/QtLocation.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/QtContacts.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/QtMessaging.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/libstdcppv5.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/QtWebKit.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/QtSvg.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/QtGui.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/QtNetwork.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/QtCore.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/libpthread.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/libc.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/libm.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/euser.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/libdl.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/stdnew.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/drtaeabi.dso C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib/dfpaeabi.dso -lsupc++ -lgcc
    c:/qtsdk/symbian/tools/gcce4/bin/../lib/gcc/arm-none-symbianelf/4.4.1/../../../../arm-none-symbianelf/bin/ld.exe: warning: C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/udeb/usrt3_1.lib(ucppinit.o) uses variable-size enums yet the output is to use 32-bit enums; use of enum values across objects may fail
    Running command: C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/tools/elf2e32.exe --sid=0xeef9ca30 --version=1.256 --capability=+networkservices+location+readuserdata+writeuserdata+localservices+userenvironment+readdevicedata+writedevicedata '--linkas=QWhoWhere{00010100}[eef9ca30].exe' --fpu=softvfp --targettype=EXE --output=C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/udeb/QWhoWhere.exe --elfinput=C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/udeb/QWhoWhere.exe.sym --uid1=0x1000007a --uid2=0x100039ce --uid3=0xeef9ca30 --stack=0x14000 --heap=0x100000,0x2000000 --codepaging=paged --datapaging=default --compressionmethod=bytepair --libpath=C:/QtSDK/Symbian/SDKs/Symbian3Qt471/epoc32/release/armv5/lib
    elf2e32 : Error: E1034: DSO avkon{000a0000}.dso not found.





  • Oh ! Thanks for the info


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.