Exec format error: android deployment on virtual Ubuntu 13.04



  • Edit: I solved the problem by installing Qt 5.2 (now the release version), the Android SDK and NDK in the home directory, not in /opt. So there were some issues concerning the access rights.

    Hello everybody,

    I'm trying now for three weeks to get a simple Hello World app working on a AVD (arm). Under Windows there are no issues but I want to create a virtual workspace via VirtualBox using Ubuntu 13.04 LTS and Qt 5.2 RC1. Please don't tell me to use Qt natively, I know that it is slower and so on, this workspace should work on multiple computers without doing a new Qt setup every single time.

    "Android Config: ":http://s14.directupload.net/file/d/3459/j895kr4f_png.htm
    "Environment 1: ":http://s14.directupload.net/file/d/3459/4ufuv8qv_png.htm
    "Environment 2: ":http://s14.directupload.net/file/d/3459/cn8eif93_png.htm

    As you can see in the pictures I added the SDK, NDK, Ant and OpenJDK, as described in "This documentation":http://qt-project.org/doc/qt-5.1/qtdoc/android-support.html

    I tried with a Qt Designer Interface including a Button and a Checkbox, and furthermore with "this example":http://qt-project.org/doc/qtcreator-2.8/creator-android-app-tutorial.html

    The result is always the same:

    @:-1: Fehler: error trying to exec '/opt/android-ndk-r9b/toolchains/arm-linux-androideabi-4.8/prebuilt/linux-x86/bin/../lib/gcc/arm-linux-androideabi/4.8/../../../../arm-linux-androideabi/bin/as': execv: Exec format error
    :-1: Fehler: [main.o] Error 1@

    "Error: ":http://s1.directupload.net/file/d/3459/5qhx24wy_png.htm

    I am running Qt Creator as root. I searched various forums for this issue but couldn't find any solution, maybe you can help me. If you need more information please let me know.

    Regards,
    Clemens

    Edit: Host system is Windows 7 64 bit, the guest Ubuntu is 32 bit.



  • The full compiling report:

    @14:55:19: Führe Schritte für Projekt accelbubble aus...
    14:55:19: Starte "/usr/bin/make" clean
    rm -f qrc_accelbubble.cpp
    rm -f main.o qrc_accelbubble.o
    rm -f *~ core *.core
    14:55:19: Der Prozess "/usr/bin/make" wurde normal beendet.
    14:55:19: Unveränderte Konfiguration, qmake-Schritt wird übersprungen.
    14:55:19: Starte "/usr/bin/make"
    /opt/android-ndk-r9b/toolchains/arm-linux-androideabi-4.8/prebuilt/linux-x86/bin/arm-linux-androideabi-g++ -c -Wno-psabi -march=armv5te -mtune=xscale -msoft-float -ffunction-sections -funwind-tables -fstack-protector -fno-short-enums -DANDROID -Wa,--noexecstack -std=gnu++0x -g -g -gdwarf-2 -marm -O0 -fno-omit-frame-pointer -Wall -Wno-psabi -W -D_REENTRANT -fPIE -DQT_OS_ANDROID_GCC_48_WORKAROUND -DQT_QML_DEBUG -DQT_DECLARATIVE_DEBUG -DQT_QUICK_LIB -DQT_SVG_LIB -DQT_QML_LIB -DQT_WIDGETS_LIB -DQT_XML_LIB -DQT_SENSORS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/opt/Qt5.2.0/5.2.0-rc1/android_armv5/mkspecs/android-g++ -I../accelbubble -I/opt/Qt5.2.0/5.2.0-rc1/android_armv5/include -I/opt/Qt5.2.0/5.2.0-rc1/android_armv5/include/QtQuick -I/opt/Qt5.2.0/5.2.0-rc1/android_armv5/include/QtSvg -I/opt/Qt5.2.0/5.2.0-rc1/android_armv5/include/QtQml -I/opt/Qt5.2.0/5.2.0-rc1/android_armv5/include/QtWidgets -I/opt/Qt5.2.0/5.2.0-rc1/android_armv5/include/QtXml -I/opt/Qt5.2.0/5.2.0-rc1/android_armv5/include/QtSensors -I/opt/Qt5.2.0/5.2.0-rc1/android_armv5/include/QtNetwork -I/opt/Qt5.2.0/5.2.0-rc1/android_armv5/include/QtGui -I/opt/Qt5.2.0/5.2.0-rc1/android_armv5/include/QtCore -I. -I/opt/android-ndk-r9b/sources/cxx-stl/gnu-libstdc++/4.8/include -I/opt/android-ndk-r9b/sources/cxx-stl/gnu-libstdc++/4.8/libs/armeabi/include -I/opt/android-ndk-r9b/platforms/android-9/arch-arm/usr/include -I. -o main.o ../accelbubble/main.cpp
    arm-linux-androideabi-g++: error trying to exec '/opt/android-ndk-r9b/toolchains/arm-linux-androideabi-4.8/prebuilt/linux-x86/bin/../lib/gcc/arm-linux-androideabi/4.8/../../../../arm-linux-androideabi/bin/as': execv: Exec format error
    make: *** [main.o] Error 1
    14:55:25: Der Prozess "/usr/bin/make" wurde mit dem Rückgabewert 2 beendet.
    Fehler beim Erstellen/Deployment des Projekts accelbubble(Kit: Android für armeabi (GCC 4.8, Qt 5.2.0))
    Bei der Ausführung von Schritt 'Make'
    14:55:25: Verstrichene Zeit: 00:06.@


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.