[solved] Please Help! Installing Qt 5.1.1 on Ubuntu 13.04 32 bit



  • Hi Everyone! I'm new to both Linux and Qt programming. Could you please give me a step by step instruction on how to install Qt creator. I have searched the forum on procedures or tutorials on to install it on Ubuntu, but found different version of Qt creator. Dont know if I should follow procedure though I intend a different version.

    I have already downloaded _ qt-linux-opensource-5.1.1-x86-offline.run_ file from the download section. What should I do next. Thanks in advance for taking time reading and answering my post :-D


  • Moderators

    Hi,

    Just run the file you downloaded :)

    You might need to give it execution permission first (right-click on it and select Properties)



  • Thanks JKSH for the quick response. Is that really that easy? ^_^ Articles I have found in the net is using the terminal and modifying the file and bunch of stuff I don't know. As I said I'm new at ubuntu. So sorry for sounding such a noob :-D

    Moving along. I have successfully installed Qt Creator on Ubuntu (thanks to your help). I have created my first program but I have come across an error when compiling. I think its about the compiler is not set up. Could you please tell me how to fix this.

    I have Qt Creator on windows, and I have also used the same code. It is running correctly on windows but on Ubuntu its not. Thanks in advance for your reply :-D


  • Moderators

    You're welcome! I'm glad to hear you're making progress. Please don't feel the need to apologize; we all move forward by learning :)

    Anyway, Ubuntu doesn't provide a C++ compiler by default. Download and install g++ from the Ubuntu Software Center.



  • Hello again. Downloaded and installed g++ from the Ubuntu Software Center. I tried to run program once again. And again another error pop-up. I tried to run some examples from Qt creator and the same error occured.
    _"/home/erick/Qt5.1.1/5.1.1/gcc/include/QtGui/qopengl.h:110: error: GL/gl.h: _No such file or directory" and the error is showing besides # include <GL/gl.h>. Im assuming it is about linking libraries to Qt Creator. Correct me If Im wrong though. What steps should I make to fix this? Thanks again for your help in advance :-D


  • Lifetime Qt Champion

    Hi,

    You need to install the libgl1-mesa-dev package



  • It's funny that you're facing the problems one by one, each beign slashed by forum members as you reply :P



  • @SGaist: Everythings working fine now after the installation. Its time for me to start coding and start learning more. Many thanks to you! :-D

    @Skyrpex: I don't get it. With all do respect, all I see is that I have a question and they are just providing me with an answer. Simple as that. Dont see the humor in it. Its your opinion, and I do respect it. Thanks for having time to read my post :-D

    Have a good day to you all! Happy coding everybody :-D


  • Lifetime Qt Champion

    You're welcome !

    Skyrpex was just referring to the short time elapsed between you asking a question and getting an answer.

    You were a lucky guy getting answers so quickly that's all :)

    Please update the thread title prepending [solved] now that you have everything up and running, so other forum users may know a solution has been found :)



  • Oh!!! Now I got it. Thanks for the clarificattion. And yes, I'm very lucky and fortunate meeting you all :-D Again, thank you so much! :)



  • I'm sorry if I did sound harsh or something. It wasn't my intention. SGaist explained it pretty well :)

    Actually, this post is useful to me because I'm facing the same problems every time I install linux in my computer.

    Regards!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.