Important: Please read the Qt Code of Conduct -

Failed to load platform plugin "windows".

  • I built Qt5 64-bit with -platform win32-msvc2012 -opengl es2 -angle <path> on Windows 8.

    Whenever I try to compile and run a Qt program, I get the following error:
    @Failed to load platform plugin "windows".
    Available platforms are:

    If I build without ANGLE support, it works, but I need ANGLE to use OpenGL shaders.

    It wasn't doing this before, but now it seems to happen no matter what. I've tried a number of qt5 repository pulls from different dates, different ANGLE repository pulls... even a fresh install of Windows and I still get the same error.

    I traced a debug build, and it sees the platform plugin, but it seems that LoadLibrary is failing when trying to load it. Any ideas how to resolve this?

  • Actually, I found the problem. ANGLE's libEGL.dll also needed to be in the path, not just libGLESv2.dll.

    Thanks to toothrot in IRC for having me try Dependency Walker.

  • Cool.. :)

  • it's the "libEGLd.dll" not the "libEGL.dll"

    but thanks, this was puzzling me.

  • Which library depends on libEGL? libGLES or Qt5Widgets, Qt5Gui? Since, using Dependency Walker, neither my Qt 5 application's executable, nor the libraries it depends on, depend on libEGL. I presume it is loaded dynamically.

  • I've found that it is qwindows.dll platform plugin that depends on libEGL.

  • Hi people,

    I have the same problem.

    I copied .exe file in separate folder, along with many .dll files.
    On the computer where I developed the application, everything works.

    However, on the other computers there is still a message:

    Failed to load platform plugin "windows". Available platforms are:

    (Press Retry...)

    I also included qwindowsd.dll.

    Can someone help?

    Thank you,


  • See "this thread": for a list of dll's and folder structure.

  • It helped me! The problem was in folder structure.

    Thank you very much!


  • Lifetime Qt Champion


    Have a look at the "deployment": documentation.

    Did you put your platform plugin in the platform subdir ? (Not in the plugins subdir)

    And are you sure you want do deploy the debug version (unless it's a typo)? The debug runtime from visual studio are not redistributable.

    Hope it helps

  • I solved that already (sent in previous email :)), but thanks anyway!

  • THANK YOU MByte! I am using libGLESv2.dll and was having the exact same problem: The pop-up

    ..could not find or load the Qt platform plugin windows..

    when trying to run the EXE-file. I could not resolve this until adding libEGL.dll to the same folder as my .EXE.
    How is one supposed to figure this out?
    This needs be explained somewhere - It took me 4 h. to find this!
    Someone please add to QT documentation!
    Carl Stenquist, Renesas

  • I still cannot solve this issue. I've added qwindows.dll and libEGL.dll and any other dll I could find and I still get the same popup error.

    1. Look at what DLLs are loaded when you run the code in QT-Creator.
    2. The DLLs must be for the sytem you are running, that is 32 OR 64 bit; the right version.
    3. For my app, I needed qwindows.dll, qminimal.dll, qoffscreen.dll in a "platforms" directory under the executable.
      But all such info seems missing in the QT documentation.

  • Moderators

    [quote author="mphair" date="1392983929"]I still cannot solve this issue. I've added qwindows.dll and libEGL.dll and any other dll I could find and I still get the same popup error.[/quote]Hi,

    Did you put them in the correct folders? See

  • JKSH
    How did you find that page - other than by through a search? I cannot see a link to it on the Wiki Home page.

    Is the page so new that it is not linked to the main page yet?

  • Lifetime Qt Champion

    He wrote it :)

  • Worked for me after I did the following:

    1. include "$(QTDIR)\include\QtANGLE" to the project
    2. include "libEGL.dll" in the .exe directory (libEGLd.dll if debug)
    3. put "qwindows.dll" in "platforms\qwindows.dll"
      bq. See this thread [] for a list of dll’s and folder


  • None of these solutions works on a Win 8.0 machine. I'm trying to use Harbour with QT which has proven to be nothing but a complete waste of time and effort. Countless hours spent chasing BS issues that should never exist. I have the dll's in the folders described and it does not work! In my opinion, do not waste your time with Harbour and QT. I also hate C++ so QT is not for me. I'm going back to a real development environment, .NET!!!!!!

Log in to reply