Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Building Qt5 source code fails 'No suitable compiler found in PATH. Aborting.'



  • Hi,

    I need older version of Qt5 (5.6.0) and I keep getting the same error. This is my step (I am trying to be super specific so here I go).

    1. I use Windows 10

    2. I have MSVC2015 (I need this version..). So all of these, I worked in Developer Command Prompt for VS2015

    3. clone qt repository ... fetched it, perl init-repository worked perfectly in git bash...

    4. When I run ..\qt5\configure -developer-build -opensource -nomake tests -nomake example I get the error saying

    C:\Users\DELL\Desktop\qt5-build>..\qt5\configure
    + cd qtbase
    + C:\Users\DELL\Desktop\qt5\qtbase\configure.bat -top-level
    Please wait while bootstrapping configure ...
    <srcbase> = C:/Users/DELL/Desktop/qt5/qtbase
    <outbase> = C:/Users/DELL/Desktop/qt5-build/qtbase
    No suitable compiler found in PATH. Aborting.
    
    1. Here is my PATH
    >> echo %PATH%
    C:\Perl64\bin;C:\Users\DELL\AppData\Roaming\ActiveState\bin;C:\Program Files\dotnet\;C:\Users\DELL\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm;C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin;C:\Users\DELL\AppData\Local\Programs\Python\Python39\Scripts\;C:\Users\DELL\AppData\Local\Programs\Python\Python39;C:\Users\DELL\AppData\Local\atom\bin;C:\Users\DELL\.dotnet\tools;C:\Program Files (x86)\Windows Kits\10\bin;C:\Program Files\Git\bin;C:\Program Files\Git\cmd;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files\CMake\bin;
    

    C:\Perl64\bin;
    C:\Users\DELL\AppData\Roaming\ActiveState\bin;
    C:\Program Files\dotnet;
    C:\Users\DELL.dnx\bin;
    C:\Program Files\Microsoft DNX\Dnvm;
    C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin;
    C:\Users\DELL\AppData\Local\Programs\Python\Python39\Scripts;
    C:\Users\DELL\AppData\Local\Programs\Python\Python39;
    C:\Users\DELL\AppData\Local\atom\bin;
    C:\Users\DELL.dotnet\tools;
    C:\Program Files (x86)\Windows Kits\10\bin;
    C:\Program Files\Git\bin;C:\Program Files\Git\cmd;
    C:\Windows\System32\WindowsPowerShell\v1.0;
    C:\Program Files\CMake\bin;

    I have been struggling for a while.. If someone can help me with this. That will be fantastic ;(


  • Lifetime Qt Champion

    Hi,

    Did you checkout the corresponding branch ?

    In any case, you should rather start from the archive.

    You can then follow the build instructions from the documentation.

    In any case, even if locked to the 5.6 series, I would recommend to use the latest minor release available for it rather than the .0 release.


Log in to reply