Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QT on mac, cmake problem?



  • Hello,

    I installed QT 5.15.2 using the current web install process on a mac with the latest OS and the default install process.

    However, I can not build my app...

    Apparently, the kit is wrong. it displays the following warning:
    "cmake version is unsupported. please update to version 3.14 (with file-api) or later"
    However, the cmake that was auto installed by QT seems to be 3.19.2 (which is later than 3.14).

    What do I need to do to fix this?

    Thanks,
    Cyrille


  • Lifetime Qt Champion

    @Cyrille-de-Brebisson said in QT on mac, cmake problem?:

    What do I need to do to fix this?

    Did you check which cmake executable is set in QtCreator (Kits/CMake)?



  • hello,

    Yes, it only shows the version 3.19.2

    Cyrille



  • @Cyrille-de-Brebisson Hi,
    have you successfully installed Xcode and command-line-tools? In your kits, where do compiler paths point to?



  • hello,

    Yes, I have installed xcode and the command line tools as you can see here:
    note: xcode is version 12.4 (12D4e)

    MacBook-de-Cyrille:HPAccessoryCenter cyrilledebrebisson$ xcode-select --install
    xcode-select: error: command line tools are already installed, use "Software Update" to install updates
    MacBook-de-Cyrille:HPAccessoryCenter cyrilledebrebisson$ 
    

    The compiler path point to /usb/bin GCC and clang
    All auto detected/setup at QT install time.
    cyrille



  • You can just edit the kit settings - there is separate entry for CMake, just enter the path there and see?



  • Hello,

    in the kit settings, it just says "CMake 3.19.2 (Qt)" there is no path.
    When I click on "manage"for cmake, it shows a path /Users/cyrilledebrebisson/Qt/Tools/CMake//CMake.app/Contents/MacOS/CMake

    This is the only option that I have for cmake.

    Cyrille



  • @Cyrille-de-Brebisson [Preferences] --> [Kits] --> [CMake] tab.
    You have there autodetected versions and ability to add manually.

    However I never used CMake with Qt 5, only Clang.

    CMake provided with Qt worked ok in Qt 6 though.



  • Hello,

    Unfortunately, our app does not work with QT6 because it requires modules that are not yet available...

    So the question is: how do I configure things and how do I download versions that will work together.

    I am more of a windows user normally, so I am not that knowledgeable on mac.
    My mac auto updated to the latest macOS, then I had to update xcode as the previous version stopped working. and the version of QT that I had installed stopped working when I updated xcode. So I reinstalled QT and now QT can not build... which is kind of frustrating :-(

    Cyrille



  • @Cyrille-de-Brebisson Search for CMake installation packages on CMake webpage, install the one required, point the paths in Qt where needed.
    In terminal/console you can, after installation, get full path needed by running command which cmake



  • OK, so I got so frustrated with the whole thing that I wiped out my mac HD and did a fresh install.
    Installed "Big Sur", installed homeBrew and used it to install svn (home brew also installs xcode command lines tools), downloaded my code, installed QT, using the default QT 5.15 version.

    This is where I saw the first error:
    9259ac8d-08dd-48a1-9631-3e59ec341e94-image.png

    But xcode IS installed and setup as I can start it and start a project.
    Also, the command lines tool are installed:
    xcode-select --install
    xcode-select: error: command line tools are already installed, use "Software Update" to install updates

    When I opened my project and try to compile it, I get the following errors (taken from the longer out text):

    Print: Entry, ":com.apple.actool.compilation-results:output-files", Does Not Exist
    
    
    xcode-select: error: tool 'actool' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance
    make[1]: *** [/Users/cydeb/Desktop/hpac/HPAccessoryCenter/asset_catalog_compiler.Info.plist] Error 1
    make[1]: *** Waiting for unfinished jobs....
    make: *** [sub-HPAccessoryCenterMain-pro-make_first-ordered] Error 2
    11:29:42: Le processus "/usr/bin/make" s'est terminé avec le code 2.
    Erreur lors de la compilation/déploiement du projet HPAccessoryCenter (kit : Desktop Qt 5.15.2 clang 64bit)
    The kit Desktop Qt 5.15.2 clang 64bit has configuration issues which might be the root cause for this problem.
    When executing step "Make"
    

    looking in the kits, the only "problem" is that Cmake warning, saying it needs 3.14 or higher, while 3.19 is installed.

    Cyrille



  • After installing Cmake 3.14, it still does not work. the errors are basically the same, except that it does not complain about mis-configured kit:

    xcode-select: error: tool 'actool' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance
    make[1]: *** [/Users/cydeb/Desktop/hpac/HPAccessoryCenter/asset_catalog_compiler.Info.plist] Error 1
    make[1]: *** Waiting for unfinished jobs....
    make: *** [sub-HPAccessoryCenterMain-pro-make_first-ordered] Error 2
    12:18:05: Le processus "/usr/bin/make" s'est terminé avec le code 2.
    Erreur lors de la compilation/déploiement du projet HPAccessoryCenter (kit : Desktop Qt 5.15.2 clang 64bit)
    When executing step "Make"
    

    Cyrille


  • Lifetime Qt Champion

    Hi,

    @Cyrille-de-Brebisson said in QT on mac, cmake problem?:

    xcode-select: error: tool 'actool' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance

    Looks like Xcode is actually required.

    Note that Qt is only officially supported using Apple's Xcode so going with other sources for the command line tools is not something that has been tested nor is supported.



  • Hello,

    But xcode is installed, so are the xcode command line tools.

    Cyrille


  • Lifetime Qt Champion

    Which version did you install ?


Log in to reply