Problems with Open-Source Downloads read https://www.qt.io/blog/problem-with-open-source-downloads and https://forum.qt.io/post/638946

Qt Cmake configuration has no path to a C++ compiler set



  • Hi!

    Yesterday, while working with QtCreator I got the typical warning stating that some updates were available. As usual, I decided to apply these.

    To my surprise, now I cant work with Qt. Each time I try to open a project, no matter what it is, I get an error stating that the cl compiler for CMake can't be found.

    Curious, since my project uses no CMake at all. I have surfed the web looking for a solution and tried several of these, to no avail.

    It looks like the kits I've installed have a misconfiguration problem. Checking the options and then the kits, this is what I see (for the 64-bit kit):

    kit_settings.jpg

    Until the update of Qt, everything worked like a charm. Of course, MSVS2015 is installed and works well when used as a standalone tool (not in tandem with Qt). It is only after the update that Qt complained.

    Of course, I tried to uninstall and reinstall Qt, again to no avail.

    The situation now is that I'm stuck and that I cannot keep working in my project, which is a rather.... annoying.... situation.

    Any help?

    Configuration:

    • Windows 10 2020 H2 up to date.
    • Qt MSVC2015 5.9.2 for both 32/64 bits.

    Thank you very much in advance.



  • Sorry, but in my previous post I didn't notice that the image was incorrectly cut.

    Here's the correct one:

    kit_settings.jpg

    Thanks.


  • Moderators

    IIRC this happens if you start Qt Creator 4.15, but then later on move back to an older Qt Creator version.

    You can try to mitigate this by clicking 'Change...' in the 'CMake COnfiguration' of your kit, and then 'Reset'.



  • Thanks, khoehne.

    I have never used QtCreator 4.15, since in my computer 4.14 is the version that got installed when the last update took place.

    I have solved (miraculously) the problem. I uninstalled Qt, CMake & Visual Studio Community edition 2015. Then I reinstalled everything. It didn't work. That was yesterday, very late. This morning, after the laptop was shut down yesterday and switched on this morning the problem... simply vanished.

    Now I'm ready to work, but this misconfiguration problem got me against the ropes and panting for more than 12 hours.

    Thanks for your help.



  • I was too quick to say that the problem was solved.

    It is true that now there are no complains about the Cmake configuration. The kits seem to be correctly configured.

    I can edit my source code.

    But I cannot compile it. As soon as I try to do it, I get the message "Failed to find Windows kit" (or something alike).

    I'm reinstalling once again, changing from 5.9 to 5.15, the latest LTS, to see if this solves the problem.



  • Finally, it's working.

    This is how I proceeded and these the results:

    Uninstall the original Qt 5.9.2 package. Uninstall VS2015. Uninstall CMake. Clean the registry (using CCleaner) to remove any references to Qt, CMake or VS2015 in my system. Restart the system. Reinstall the same components (Qt 5.9.2, last version, in this case, of CMake, and VS2015). Result: the original problem remained (CMake misconfiguration in Qt).

    Uninstall Qt 5.9.2. Clean the registry. Restart the system. Install the latest 5.9 version of Qt (can't recall the third level number, but as I say, it was the last one for 5.9). Result: the problem concerning the misconfiguration of Qt vanished. Apparently, all kits were properly configured. However, trying to compile a project produced the "Unable to find the Windows development kit" stated in my previous post.

    Uninstall Qt 5.9.last_sub_sub_version. Clean the registry. Restart the system. Install the latest LTS available from Qt (15.5.2). Result: I can compile my projects without problems. The issue is solved.

    I don't know what was going on, but I've been forced to jump from 5.9.2 to 5.15.2, quite a long distance between versions. Fortunately, it seems that my most complicated project using Qt compiles correctly.

    Can someone explain this weird issue? To me, it sounds like a problem with the latest version of Qt Creator, since this tool was one of the components changed when the update was applied.

    At any rate, I can keep working after two days of struggling with a misconfiguration problem with the tool.

    All's well that ends well (Shakespeare) --- but sometimes it has a high cost (myself).


Log in to reply