Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Executing a GUI app on a remote debug target via QProcess and a console app



  • Hi,

    I have a console service application which controls rest of the system components. The whole system is a remote target which runs on Linux (namely Raspbian). I've set up my development environment right and can debug my console application remotely. No problems there.

    One of the system components is a GUI/QML application and I want it to be executed by my main control application via QProcess. The idea actually works if I trigger the execution on the remote target directly (via local inputs or VNC connection).

    Problem starts if I try to debug the setup remotely. The console application starts remotely and GDB multiarch connects successfully. But the process which started by the QProcess fails and debugger outputs the message seen below:

    Detaching from process <nnnn>
    

    This means the application closes somehow (I don't know the root cause, maybe a seg fault) and does not continue the execution. I can confirm that via process listing. The process is not there.

    My question is, what can I do to be able to execute this GUI component normally while remote debugging? I'd like to see the output on remote targets display but if I can not, seeing it on my local machine is OK, too.

    Regards,

    Qt 5.15, Dev: Ubuntu 20.04 -> Remote Target: Raspbian, Kernel 5.4.51


  • Lifetime Qt Champion

    Hi,

    Might be a silly question but if you want to debug that specific application, why not execute it directly from Qt Creator like you do with your console application ?



  • No, it's a rightful question. This GUI component is optional and exists for auxilary tasks. The console app is the core of the system and I'd like to debug it in the first place.

    I'm planning to connect via GDB on the fly to this kind of other system components if I have to. Normally I'll be seeing everything on that core console app.

    By the way I've asked for help to debug that UI app directly on the embedded forum but with no luck. Still waiting for a response :)

    Here: https://forum.qt.io/post/614152



  • As I've solved my own question in https://forum.qt.io/post/614152 thread, I'm marking this one as solved.


Log in to reply