Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Project ERROR: Unknown module(s) in QT: webenginewidgets in RPI4


  • Lifetime Qt Champion

    @mvsri So, "sudo apt install libqt5webenginewidgets5" does not work?

    "I tried updating it but it get stuck there" - you mean "git submodule update --init"? What exactly happens then?



  • @jsulm yes "sudo apt install libqt5webenginewidgets5" does not work.
    and for your second question when i run "git submodule update --init" i get the following message

    Submodule 'src/3rdparty' (git://code.qt.io/qt/qtwebengine-chromium.git) registered for path 'src/3rdparty'
    Cloning into '/home/pi/qtwebengine/src/3rdparty'...
    

    and nothing happens


  • Lifetime Qt Champion

    @mvsri Chromium is quite big as far as I know, maybe you should wait a bit longer?



  • @jsulm right now what i'm trying to do is.
    clone chromium from
    git clone git://code.qt.io/qt/qtwebengine-chromium.git/
    and try to build it from there for 5.11.3 version.
    I don't know if it's right but i think it's worth a try.



  • @jsulm i cloned the qtwebengine-chromium and now when i run

    "qmake -r"
    

    i am getting the following error

    Running configuration tests...
    Done running configuration tests.
    
    Configure summary:
    
    Qt WebEngine:
      Embedded build ......................... no
      Pepper Plugins ......................... yes
      Printing and PDF ....................... yes
      Proprietary Codecs ..................... no
      Spellchecker ........................... yes
      Native Spellchecker .................... no
      WebRTC ................................. yes
      Use System Ninja ....................... yes
      Geolocation ............................ no
      Use v8 snapshot ........................ yes
      Use ALSA ............................... yes
      Use PulseAudio ......................... yes
      Optional system libraries used:
        re2 .................................. no
        icu .................................. no
        libwebp, libwebpmux and libwebpdemux . no
        opus ................................. no
        ffmpeg ............................... no
        libvpx ............................... no
        snappy ............................... no
        libsrtp .............................. no
        glib ................................. yes
        zlib ................................. yes
        minizip .............................. no
        libevent ............................. no
        jsoncpp .............................. no
        protobuf ............................. no
        libxml2 and libxslt .................. yes
        lcms2 ................................ no
        png .................................. yes
        JPEG ................................. yes
        harfbuzz ............................. no
        freetype ............................. no
      Required system libraries:
        fontconfig ........................... no
        dbus ................................. yes
        nss .................................. yes
        khr .................................. yes
        glibc ................................ yes
      Required system libraries for qpa-xcb:
        libdrm ............................... yes
        xcomposite ........................... yes
        xcursor .............................. yes
        xi ................................... yes
        xrandr ............................... yes
        xtst ................................. yes
    
    Qt is now configured for building. Just run 'make'.
    Once everything is built, Qt is installed.
    You should NOT run 'make install'.
    Note that this build cannot be deployed to other machines or devices.
    
    Prior to reconfiguration, make sure you remove any leftovers from
    the previous build.
    
     
    A suitable version of fontconfig could not be found.
    QtWebEngine will not be built.
    
    

    how to solve fontconfig error?


  • Lifetime Qt Champion

    @mvsri said in Project ERROR: Unknown module(s) in QT: webenginewidgets in RPI4:

    how to solve fontconfig error?

    install fontconfig-dev package.



  • @jsulm it's already installed but still i get error


  • Lifetime Qt Champion

    @mvsri Then check config.log file to see why fontconfig is set to "no"



  • @jsulm i checked in config.log and i found this

    loaded result for library config.qtwebengine.libraries.webengine-fontconfig
    Trying source 0 (type pkgConfig) of library webengine-fontconfig ...
    + /usr/bin/arm-linux-gnueabihf-pkg-config --exists --silence-errors fontconfig
    pkg-config did not find package.
      => source produced no result.
    test config.qtwebengine.libraries.webengine-fontconfig FAILED
    

  • Lifetime Qt Champion

    @mvsri To be sure: you're building on RaspberryPi and you installed fontconfig and fontconfig-dev there?



  • @jsulm yes i'm using rpi4 and i have installed fontconfig and fontconfig-dev and according to this https://doc.qt.io/qt-5/linux-requirements.html i also installed

    libfontconfig1-dev
    

    but still i'm getting the error



  • This post is deleted!


  • @jsulm in config cache file i found this

    cache.webengine-fontconfig._KEYS_ = result msgs
    cache.webengine-fontconfig.result = false
    cache.webengine-fontconfig.msgs = "Trying source 0 (type pkgConfig) of library webengine-fontconfig ..." "+ /usr/bin/arm-linux-gnueabihf-pkg-config --exists --silence-errors fontconfig" "pkg-config did not find package." "  => source produced no result."
    

    can anyone tell me how to link fontconfig lib here.


  • Lifetime Qt Champion

    @mvsri Sorry, I don't know why it doesn't work. Maybe somebody else can help.



  • @jsulm it's okay. maybe someone can help me here. Thanks for your quick response though



  • @jsulm Hey there,
    I'm trying to install QT 5.12.8 with qtwebengine following the steps from this link
    https://www.tal.org/tutorials/building-qt-512-raspberry-pi

    when i'm using

    make
    

    i get the following error

    ninja: build stopped: subcommand failed.
    make[4]: *** [Makefile.gn_run:1087: run_ninja] Error 1
    make[4]: Leaving directory '/home/pi/Desktop/qt-everywhere-src-5.12.8/qtwebengine/src/core'
    make[3]: *** [Makefile:82: sub-gn_run-pro-make_first] Error 2
    make[3]: Leaving directory '/home/pi/Desktop/qt-everywhere-src-5.12.8/qtwebengine/src/core'
    make[2]: *** [Makefile:81: sub-core-make_first] Error 2
    make[2]: Leaving directory '/home/pi/Desktop/qt-everywhere-src-5.12.8/qtwebengine/src'
    make[1]: *** [Makefile:49: sub-src-make_first] Error 2
    make[1]: Leaving directory '/home/pi/Desktop/qt-everywhere-src-5.12.8/qtwebengine'
    make: *** [Makefile:1005: module-qtwebengine-make_first] Error 2
    

    Do you have any idea what could the problem be?
    I also checked the file in path

    /home/pi/Desktop/qt-everywhere-src-5.12.8/qtwebengine/src/core/Makefile.gn_run
    

    it is as follows

    run_ninja:
    ninja -v -C /home/pi/Desktop/qt-everywhere-src-5.12.8/qtwebengine/src/core/release QtWebEngineCore
    

  • Lifetime Qt Champion

    @mvsri said in Project ERROR: Unknown module(s) in QT: webenginewidgets in RPI4:

    Do you have any idea what could the problem be?

    You did not post the actual errors, those should be above what you posted.



  • @jsulm
    It's a very lengthy data after going through this i can found this
    "FAILED: libosmesa.so "

    ../../3rdparty/chromium/third_party/pdfium/third_party/libopenjpeg20/opj_clock.c -o obj/third_party/pdfium/third_party/fx_libopenjpeg/opj_clock.o
    [5/10450] /usr/bin/g++ -shared -Wl,--fatal-warnings -Wl,--build-id=sha1 -fPIC -Wl,-z,noexecstack -Wl,-z,now -Wl,-z,relro -Wl,-z,defs -Wl,--as-needed -fuse-ld=gold -B../../3rdparty/chromium/third_party/binutils/Linux_x64/Release/bin -Wl,--icf=all -Wl,-O2 -Wl,--gc-sections -rdynamic -o "./libosmesa.so" -Wl,-soname="libosmesa.so" @"./libosmesa.so.rsp"
    FAILED: libosmesa.so 
    /usr/bin/g++ -shared -Wl,--fatal-warnings -Wl,--build-id=sha1 -fPIC -Wl,-z,noexecstack -Wl,-z,now -Wl,-z,relro -Wl,-z,defs -Wl,--as-needed -fuse-ld=gold -B../../3rdparty/chromium/third_party/binutils/Linux_x64/Release/bin -Wl,--icf=all -Wl,-O2 -Wl,--gc-sections -rdynamic -o "./libosmesa.so" -Wl,-soname="libosmesa.so" @"./libosmesa.so.rsp"
    /usr/bin/ld.gold: error: obj/third_party/mesa/osmesa/driverfuncs.o uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/osmesa/meta.o uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/osmesa/osmesa.o uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/builtin_function.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/enums.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/lex.yy.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/program_parse.tab.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/entry.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/mapi_glapi.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/stub.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/table.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/u_current.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/u_execmem.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/accum.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/api_arrayelt.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/api_exec.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/api_loopback.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/api_validate.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/arbprogram.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/arrayobj.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/atifragshader.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/attrib.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/blend.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/bufferobj.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/buffers.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/clear.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/clip.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/colortab.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/condrender.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/context.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/convolve.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/cpuinfo.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/debug.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/depth.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/dlist.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/drawpix.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/drawtex.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/enable.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/errors.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/eval.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/execmem.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/extensions.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/fbobject.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/feedback.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/ff_fragment_shader.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/ffvertex_prog.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/fog.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/format_pack.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/format_unpack.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/formats.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/framebuffer.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/get.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/getstring.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/glformats.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/hash.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/hint.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/histogram.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/image.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/imports.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/light.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/lines.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/matrix.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/mipmap.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/mm.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/multisample.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/nvprogram.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/pack.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/pbo.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/pixel.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa.a(obj/third_party/mesa/mesa/pixelstore.o) uses VFP register arguments, output does not
    /usr/bin/ld.gold: error: obj/third_party/mesa/libmesa_libglslcommon.a(obj/third_party/mesa/mesa_libglslcommon/strtod.o) uses VFP register arguments, output does not
    collect2: error: ld returned 1 exit status
    [6/10450] /usr/bin/gcc -MMD -MF obj/third_party/pdfium/third_party/fx_libopenjpeg/pi.o.d -DV8_DEPRECATION_WARNINGS -DUSE_UDEV -DUSE_AURA=1 -DUSE_NSS_CERTS=1 -DUSE_OZONE=1 -DNO_TCMALLOC -DFULL_SAFE_BROWSING -DSAFE_BROWSING_CSD -DSAFE_BROWSING_DB_LOCAL -DOFFICIAL_BUILD -DCHROMIUM_BUILD -DFIELDTRIAL_TESTING_ENABLED -DTOOLKIT_QT -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -DNDEBUG -DNVALGRIND -DDYNAMIC_ANNOTATIONS_ENABLED=0 -DOPJ_STATIC -DPNG_PREFIX -DPNG_USE_READ_MACROS -DPDF_ENABLE_V8 -DPDFIUM_PRINT_TEXT_WITH_GDI -Igen -I../../3rdparty/chromium -I../../3rdparty/chromium/third_party/pdfium -fno-strict-aliasing --param=ssp-buffer-size=4 -fstack-protector -funwind-tables -fPIC -pipe -pthread -march=armv6zk -mfloat-abi=softfp -mfpu=vfp -O2 -fno-ident -fdata-sections -ffunction-sections -fno-omit-frame-pointer -g0 -fvisibility=hidden -Wno-psabi -Wno-unused-local-typedefs -Wno-maybe-uninitialized -Wno-deprecated-declarations -fno-delete-null-pointer-checks -Wno-comments -Wno-dangling-else -Wno-packed-not-aligned -Wno-missing-field-initializers -Wno-unused-parameter -std=gnu11 -c ../../3rdparty/chromium/third_party/pdfium/third_party/libopenjpeg20/pi.c -o obj/third_party/pdfium/third_party/fx_libopenjpeg/pi.o
    ninja: build stopped: subcommand failed.
    make[4]: *** [Makefile.gn_run:1087: run_ninja] Error 1
    make[4]: Leaving directory '/home/pi/Desktop/qt-everywhere-src-5.12.8/qtwebengine/src/core'
    make[3]: *** [Makefile:82: sub-gn_run-pro-make_first] Error 2
    make[3]: Leaving directory '/home/pi/Desktop/qt-everywhere-src-5.12.8/qtwebengine/src/core'
    make[2]: *** [Makefile:81: sub-core-make_first] Error 2
    make[2]: Leaving directory '/home/pi/Desktop/qt-everywhere-src-5.12.8/qtwebengine/src'
    make[1]: *** [Makefile:49: sub-src-make_first] Error 2
    make[1]: Leaving directory '/home/pi/Desktop/qt-everywhere-src-5.12.8/qtwebengine'
    make: *** [Makefile:1005: module-qtwebengine-make_first] Error 2
    

  • Lifetime Qt Champion

    @mvsri said in Project ERROR: Unknown module(s) in QT: webenginewidgets in RPI4:

    /usr/bin/ld.gold: error: obj/third_party/mesa/osmesa/meta.o uses VFP register arguments, output does not

    Looks like your build artefacts use different ABIs than what is in third_party.
    How was third_party content build?



  • @jsulm
    http://download.qt.io/official_releases/qt/5.12/5.12.8/single/qt-everywhere-src-5.12.8.tar.xz

    i downloaded it form here and followed this steps https://www.tal.org/tutorials/building-qt-512-raspberry-pi

    according to that i can say that 3rd party content also built along with the code