Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Creator 4.12.2 Android setup



  • Hi all,

    Recently I updated Qt Creator from 4.12.1 to 4.12.2 on my Windows machine with Qt 5.15.0 and faced an issue with Android settings. Now Creator always reports that Android settings have errors:

    settings.jpg

    and asks to install missing packages:

    missing.jpg

    But when I press "Yes", nothing happens... I suspect that this issue is somehow related to NDK setup, because when I tried to reinstall Android Studio from scratch, Qt Creator asked to install missing packages too, and installed some of them (Google USB Driver, Platform-Tools and some others), but none of NDK packages. I tried to install different NDK packages manually, but it didn't help.

    Has anyone encountered this issue? Is there any solution for this? If not, is there any regular way to downgrade Qt Creator back to 4.12.1?

    Thanks in advance for your help, Oleg.


  • Lifetime Qt Champion

    Hi @KoneTaH,

    I have no idea regarding your problem (don't use Android), but you can install any older version from http://download.qt.io/official_releases/qtcreator in parallel to the version from the online installer.

    Regards



  • @aha_1980 Thank you, I have installed older version of Qt Creator (4.11.2) in parallel and thus solved the issue. BTW, I found the bugreport regarding similar issue:

    https://bugreports.qt.io/browse/QTCREATORBUG-23898


Log in to reply