Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

SDK Tools, Platform not installed



  • I am using:

    • debian
    • android ndkr21b
    • jdk1.8.0_251
    • Android SDK (via studio):
      • build tools 30rc2
      • CLI tools 30rc2
      • SDK Platform-tools

    In android device setup I am seeing everything green except 'SDK tools installed' and 'Platform SDK installed'

    I am bit a confused as I have checked that studio has a platform SDK installed and SDK platform-tools installed. Don't understand what the problem is.

    There are a lot of threads about this but most of them come down to 'install Java SDK 8' which I have.
    I've tried running the sdk manager own its own in cli and have wiped the config files - neither of which helped.

    Any ideas?



  • Since relatively recently getting the Android stuff to work is a nightmare. After it worked for a couple of years without issues it stopped working some time ago., then after considering some very helpful hints received in the forum worked again, and about a week ago blew up again.

    I don't think I can be of much help as mine's probably in a similar or even worse state but I'd suggest you that you disclose a bit more details, in particular the version of Qt you're using.



  • Thanks for your reply. It's a small amount of solace to know I'm not the only one struggling with this.
    I'm using Qt creator 4.11.2 with Qt 5.14.2.



  • Hi,

    had some problems with this myself recently, on both Ubuntu and Windows. If I understand you correctly you installed all the Android stuff using Android Studio?

    As far as I know that doesn't work for everything. For some reason the SDK tools are not installed by Android Studio. you have to download them here (the command line tools, at the bottom of the page) and copy the tools folder into your Android SDK folder. I had to do this on both platforms to make it work.



  • @Larvae I downloaded the CLI tools and put them in the same directory that android studio is looking for the SDK in and it removed the error for SDK tools, thank you!

    However it is still not finding an SDK Platform. I tried to use sdkmanager to see if I can install the platform, but I'm getting a java error trying to run it. Where did you install it from?



  • I was looking at this thread about platform SDK but the solutions there haven't worked for me. I already have Java 8 installed. I downloaded the standalone platform SDK and put it in the SDK directory. It successfully ran this time and I tried sdkmanager "platforms;android-29" which didn't throw any error messages but I don't know if it actually installed anything because Qt is still not detecting platform tools.

    I also looked at adding the verbose option but under devices->android->SDK manager there is a warning that 'SDK manager is not available with the current version of SDK tools' and it won't let me open either the advanced options menu.



  • I gave up and got it configured on windows.


Log in to reply