Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Setup Qt for android on mac



  • Hello everyone !

    I want to build an android mobile app using Qt but I don't get the "Android Settings" right.

    Here is what is not working:
    Capture d'écran 2020-04-04 21.20.43.png

    Capture d'écran 2020-04-04 21.23.53.png

    Capture d'écran 2020-04-04 21.23.14.png

    • SDK tools and Platform SDK are not found,
    • SDK manager: everything is disabled,
    • and therefore I can't select any "Android build SDK".

    The structure of my "Android" folder is as follow:
    Capture d'écran 2020-04-04 21.27.27.png

    I tried several jdk, installed several SDK and NDK, tried to install them using Android Studio, then without Android Studio by using the sdkmanager (cmdline-tools noted as (latest), several version of Qt Creator... But nothing seems to work.

    What am I missing ?

    Currently, my setup is:

    • Qt Creator 4.11.2, based on Qt 5.14.2,
    • Android Studio is not installed anymore,
    • Using a Mac under 10.15.3 (Catalina).

    Thanks you very much !


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    There have been several similar questions these past days. Please search the forum.



  • Hi !

    Thank you for your answer.
    I did search the forum before posting but nothing seems to help for now.

    According to this https://doc.qt.io/qt-5/androidgs.html, I tried the r21 NDK this morning but nothing changed.
    Also tried with r10e NDK (and others) and older platforms, build tools, like android-15 or android-25 but still same results.

    Also tried with Qt 5.13.2 but same results (except maybe that with the 5.14.2 I got only 2 kits with the same name "Android for armeabi-v7a,arm64-v8a,x86,x86_64", one with the "Clang" compiler (definde as default) and the other one with "Android Clang", but it seems I can't change their names).



  • @Qims You have to install Android SDK Tools. Please take a look to this post: https://forum.qt.io/post/585927, this will show you how to do it.



  • Hi !

    Thank you, it seems that SDK tools is now detected !
    But "SDK manager runs" is not found (red cross) anymore and "Platform SKD installed" is still not found.

    I tried several version of jdk (1.8) but their not detected, i am currently using:

    java -version:
    java version "1.8.0_241"
    Java(TM) SE Runtime Environment (build 1.8.0_241-b07)
    Java HotSpot(TM) 64-Bit Server VM (build 25.241-b07, mixed mode)

    What is installed:
    Capture d'écran 2020-04-06 20.51.37.png

    • NDK r10e installed separately.

    The SDK Manager is now clickable in Qt Creator but still no displayed package.



  • i have the same problem in my kits Android is not showing,if it shows it does configure for the project.
    help me out
    thank you!!



  • Hi !

    Still have the problem, does anyone as a solution ?

    I found this link : https://doc.qt.io/qt-5/supported-platforms.html about the Android build environment.
    It is written "mac os 10.13", does it mean that we have to use this specific version of the OS or does it mean this OS and higher to build android apps ?


Log in to reply