Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Creating 3D-Studio Executable with Deployment Tool - White Screen



  • Hello Everybody!

    I'm currently trying to create a usable Executable for my 3D-Studio Project.

    Therefore, I used the Windows Deployment Tool with the command "--quick ."

    The Deployment Tool then copied a Tone of .dlls into my Folder, but the .exe always shows only a White Screen.

    I've tried to do it step by step by myself with the "Quick and Dirty" - Tutorial. But this also didn't work...

    To Analyze what the problem could be, I've used the Dependency Walker and profiled the Executable.

    It looked like this:

    a1d0cc3a-397e-47b4-8645-49fcae333d5b-grafik.png

    Also, a few Errors showed up, like:

    d0d18076-652d-43f0-8202-3d49160ee8fd-grafik.png
    But I think, these are not the actual problem.

    There's another Error which says:

    "LoadLibraryW("<ProgramPath>\OpenGL\declarative_qtstudio3dopengl.dll") returned NULL. Error: Couldn't find the Prodecure (126).
    -- qrc:/main.qml: Type Presentation3D unavailable
    -- qrc:/Presentation3D.qml: plugin cannot be loaded for module "QtSTudio3D.OpenGL": Cannot load library <ProgramPath>\declarative_qtstudio3dopengl.dll - The module couldn't be found.

    I think, this Error is the actual problem, because Presentation3D.qml is the File where I have my reference to the 3D-Studio-Project. But I have no idea how to handle it.

    I've tried to create an qml/<ProjectName>/ Directory into the Executable Folder, where I copied all the qml-Files in. But this also didn't work... still a White Screen.

    Could you help me here?

    Environment:
    Visual Studio - MSVC 2017
    Qt 5.12.4.
    QtStudio3D.OpenGL 2.4 (Open GL Runtime for 5.12.4)

    Project includes:
    qml.qrc -> Path to qml-Files
    digitalcluster.qrc -> Path to all 3D-Studio Resources
    QML-Files
    C++-Sources-Files
    C++-Header-Files
    The 3D-Studio Project (.uip and .uia)

    Thank you in Advance!


  • Lifetime Qt Champion

    Hi
    Does the exe shows white screen on the same pc where you developed it ?
    It does seem like something up with the openGL but it cant be if the same pc where it runs via Creator.


  • Moderators

    @J_Weihele did you specify the qmldir path ?



  • @mrjj @J-Hilk
    Thank you for answering!
    It works fine as long as I'm starting it in Visual Studio (Release Mode x64), but as soon as I'm opening the Executable on the same PC, it shows a White Screen..
    Inside the qml.qrc I didn't really specify the Path.
    It's only:

    <RCC>
        <qresource prefix="/">
            <file>main.qml</file>
            <file>Simulation.qml</file>
            <file>Presentation3D.qml</file>
        </qresource>
    </RCC>
    
    

    Like this, it worked fine in Visual Studio.
    But I've also tried to specify the Path like this:

    <RCC>
        <qresource prefix="/">
            <file>C:/<<path>>/main.qml</file>
            <file>C:/<<path>>/Simulation.qml</file>
            <file>C:/<<path>>/Presentation3D.qml</file>
        </qresource>
    </RCC>
    
    

    But this didn't even work inside Visual Studio..


  • Moderators

    @J_Weihele I actually meant the --qmldiroption of the the deployment tool

    ff93b12d-57de-4b2e-97c1-ffd8c73b654c-image.png

    If you deploy QML based applications, you need to point the deployment tool to your own qml files so that it can parse them and copy all needed dlls



  • @J-Hilk No i didn't.. just tried it, but still got a White Screen and the same Errors in the Dependeny Walker :/.

    I just saw, that after I used the Deployment Tool there's a Warning between the Updating and Creating Lines which says:

    "Cannot find Visual Studio Installation Directory, VCINSTALLDIR is not set."

    I'm not sure, if this is important to solve the Problem.



  • Finally got it. I just retried the "Quick and Dirty" Tutorial (https://wiki.qt.io/Deploy_an_Application_on_Windows), where I just copied all .dlls and folders I can find into the Executable-Directory.
    Now I need to clean up this mess. A 6GB folder sounds a bit to much for my Project.

    Thank you for your support!


Log in to reply