Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Problem with tutorial links



  • Hi All,
    Sort of a puny pud problem here, but maybe someone can give me some guidance.

    On my Firefox's opening page, there is a notice at the top "Your browser is being managed by your organization." That is probably because it came from Snap. When I tried to install Firefox from Synaptic, I got the message "W: Failed to fetch http://packages.linuxmint.com/pool/upstream/f/". So I installed from Snap. I did add /Snap/bin/Firefox to the environment. Probably the fact that I cannot make Firefox the default browser is related to the notice mentioned. When I press the "Make Default" button in Firefox, I get the message "Allow snap "firefox" to change "default-web-browser" to "firefox_firefox.desktop"?". But if I press 'Yes', no change in status occurs.

    Now the real problem. In QT Creator 4.5.2, the Welcome page leads to a page of tutorial links, most of which are web-based videos. If I select one of these, I get the message "Failed to execute default Web Browser. Failed to execute child process "opera" (No such file or directory)." Opera is not installed on my machine, though it has been. I tested Opera, but found it just as ineffective as Firefox in displaying the videos. Anytime the above "Failed to execute ..." message is displayed, the Creator nanny terminal displays a message like, "Gtk-Message: 11:34:00.545: GtkDialog mapped without a transient parent. This is discouraged." There are options in Creator, and under the Tools>Options>System tab, the default entry for "External file browser" is "xdg-open %d". I have tried a number of possible variants to try to get the desired action, such as "/Snap/bin/Firefox %f", but so far none has been successful.

    Any advice?
    thanks,
    Gary Bollenbach

    Mint 19.1 as VirtualBox vm
    Firefox 69.0.3


  • Lifetime Qt Champion

    Hi,

    Did you check xdg-open settings ?



  • Hi SGaist,
    I think I solved it. The missing puzzle piece was 'Preferred Applications' in the Mint settings tree. I believe that's what gets looked at, and I wasn't aware of it.

    I think it's safest to use browsers available in Synaptic. As I said, Firefox was not, so no conclusion there. I see from surfing around that Chromium used to have a problem with this error, and apparently, from my tests, it's still there. Opera is not in the channel. I found that both Arora and Falkon work. In a nod to QT, I'll use Falkon, at least for now.

    thanks for reading the post.
    gary


Log in to reply