QEMU qml Text element does not display text



  • Hi,
    Recently I tried start developing for Meego platform. I have installed newest packets using SDKMaintenanceTool.
    I can successfully run QEMU under Linux KUbuntu.
    I tried to run qml Hello World generated by QtCreator.
    However I am unable to see text "Hello World" on QEMU Harmattan display.
    Does anyone know what can be wrong?

    @Rectangle {
    width: 400
    height: 400
    color: "green"

    Text {
        id: helloTxt
        text: qsTr("Hello World")
        anchors.centerIn: parent
        width: paintedWidth
        height: paintedHeight
        font.pixelSize: 40
        
        color: "white"
    
        Component.onCompleted: console.log("[untitled] Text: " + text + " " + width + " " + height)
    }
    
    MouseArea {
        anchors.fill: parent
        onClicked: {
            Qt.quit();
        }
    }
    

    }@

    Edited by michal.k:
    I can see that I get similar error messages as in "this":http://developer.qt.nokia.com/forums/viewthread/10262 thread:

    X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 148
    Extension: 142 (RENDER)
    Minor opcode: 25 (RenderCompositeGlyphs32)
    Resource id: 0×23



  • Just
    @text: "Hello World"@
    also didn't work?



  • Hi,
    Thanks for the suggestion. However it does not make my text displayed.
    I think that problem is in my graphics card or Xorg configuration.
    My VGA controller is: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

    For now I have to imagine that text is displayed where it should be :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.