Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

cannot run: no command



  • Hi,
    I am building a simple qt application,done with kit selection also, getting application output "cannot run:No command given" ,I am not getting whats wrong,can anyone help ,thankyou.



  • @asha
    Can you show your sample code?



  • yes,here is the attachement of sample code0_1567501643406_code.png 0_1567501654765_deviceconnection.png Please go through this and let me know what mistakes I am doing,how to solve this,



  • Hi,
    I am waiting for your suggestion,please replay me...



  • Hi,
    here is one more attachement,which shows the .pro file and error0_1567515559275_erro.png please go through this,and let me know how to proceed next...



  • @asha
    What device are you connecting ?
    Can you show me your kits configuration?



  • Hi,
    I am connecting the linux device(beagleboneboard),the kit configuration attached here0_1567571374965_kit.png .



  • Hi,
    I am waiting for your replay,


  • Lifetime Qt Champion

    @asha Please show the Qt versions and compilers tabs also.

    And be a bit more patient: People here help in their free time and live all around the world, not necessarily in the same time zone as you.

    • Did you follow a guide to set the toolchain up?
    • Which Creator version is that?

    Regards



  • Hi,

    Good Morning,

    Thankyou for the replay,

    here I am going to attach the Qtversion and compiler also please go through that
    0_1567658090275_qtversion (1).png 0_1567658108624_compiler (1).png .

    qt creator version is 5.9,sorry but the first question I am not getting..



  • One more thing I want to share,without connecting the linux device on devices(when selecting Desktop its fine),its running the application but when I am trying with selecting the general linux device getting the error :cannot run :No command given"



  • @asha said in cannot run: no command:

    I am connecting the linux device(beagleboneboard)

    Have you followed any installation/setup guide for cross-compiling Qt for the BBB device, just like this one for example?

    I don't own such device, but from previous experience with cross-compiling Qt for other devices (i.e. Raspberry Pi) and using those devices with Qt Creator, such guide seems quite acceptable.

    It also mentions something that could be really applicable to the issue you're describing:

    When you try to deploy a program on your BBB from QtCreator you may get an error about an unknown command. This is because QtCreator does not know where to copy the compiled file onto the BBB. The following line should be added to your .pro file:
    target.path = /home/Matilda/
    You may change the path to anything you want and the executable will be copied to and run from this location.
    Now you are ready to run your first Qt BBB project.



  • Sir,
    Thankyou for the replay,

    I installed the qt5 through commands.

    sudo apt-get install build-essential
    sudo apt-get install qtcreator
    sudo apt-get install qt5-default
    sudo apt-get install qt5-doc
    sudo apt-get install qt5-doc-html
    sudo apt-get install qtbase5-doc-html
    sudo apt-get install qtbase5-examples

    but after this all,

    I uninstalled the qt5,now again i installed qt5,while downloaded and executing this file :"qt-opensource-linux-x64-5.13.0.run",

    now I am getting the error0_1567761086821_permissiodenied.png

    and that is showing 2 qt versions0_1567761355986_qtv.png .

    how to remove one qt 5.9.5 in PATH(qt5)? because after uninstalling I am getting 2versions and

    please give the suggestions for :"permission denied error"

    Thankyou.


  • Lifetime Qt Champion

    @asha

    I think you need to fundamentally start at a lower point.

    So you want to compile for the BeagleBone board, which has an ARM processor. I assume you are working on a PC with Intel or AMD processor.

    So what you need to do, is to cross-compile your code to ARM. Therefore you need:

    • An ARM cross-compiler with system libraries ("toolchain")
    • A Qt version cross-compiled for ARM
    • A cross-debugger, if you want to debug on the target

    From your screenshots, I don't see a cross-compiler nor a cross-Qt version.

    Without them, it's impossible to build programs for the BeagleBone.

    Regards

    Edit: The Android versions (despite beeing ARM too), will not help you.



  • Hi,

    I installed the cross compiler ,through the following command:

    sudo apt-get install gcc-arm-linux-gnueabihf

    And installed cross debugger via

    sudo apt-get install gdb-multiarch,

    Here is the attacment of cross-debugger,cross-compiler, and kit configuration0_1567765382162_crosscompiler.png

    0_1567765403674_crossdebugger.png

    0_1567765418525_cc_BBB.png

    after this configurations and running a simple application with cross compilers and debuggers only getting error0_1567765476104_err.png ,now what is the mistake,please let me know...and installing cross compiler and debugger process is currect or wrong..and in lit configuration its showing red mark..



  • @asha your kit has error, see the RED icon in 3rd screenshot previous post. You need to check at bottom of such page to see what the message is regarding the issue...



  • Hi,

    I am getting the issue "Failed to create remote directories : mkdir: cannot create directory'/opt/aa': Permission denied...any suggestion for this..


  • Lifetime Qt Champion

    @asha said in cannot run: no command:

    /opt/aa

    /opt is a directory where only root has write access. You need to give the user write access to the directory you want to use or (better) use users home directory to deploy.



  • Sir,

    I am very new to qt,please can you elaborate how to give user write access to the /opt directory..


  • Lifetime Qt Champion

    @asha said in cannot run: no command:

    I am very new to qt,please can you elaborate how to give user write access to the /opt directory..

    That has nothing to do with Qt. /opt is a system directory, only the administrator (root) has write access there. If you need to install something there use the sudo command - but be careful, you can destroy you whole system if you do something wrong.

    Regards



  • Hi,

    opt directory has the permissions

    drwxr_xr_x,

    I changed the permissions through the command

    "chmod go+w opt"

    after this the permission of opt is
    drwxrwxrwx

    So,now again I build the application and getting the same problem.

    Any suggestions.


  • Lifetime Qt Champion

    @asha You changed the permissions on your target device?
    Also, this is a bad solution.
    Better give the user write access.



  • sir,

    how to change the permission on target device ,can you elaborate please,
    How to give the user write access.



  • Hi,

    now i changed the user write acces,that is

    drwxrwxrwx beagle1

    after this also I am getting the same problem.



  • Hi,

    I have two qt versions on my kit is there any problem?



  • Hi,

    Please tell me,how to install qt creator on ubuntu 18.04,which version qt is required,which version cross-compiler is required,how to install that one,how to install debugger also,and how to configure the kit(actually I Know this steps,but I want to confirm that, what I did either it is correct or wrong)...

    Thankyou



  • Good Morning guys,

    Any suggestions please..


  • Lifetime Qt Champion

    @asha "how to install qt creator on ubuntu 18.04" - either install one delivered with Ubuntu using apt-get, or download QtCreator from official website.
    "which version qt is required" - you should know that. Which version do you want to use, or which version is supported by your SDK?
    "which version cross-compiler is required" - the one provided by the SDK for your device.
    "how to install that one" - should be part of the SDK.
    "how to install debugger also" - should be part of the SDK.



  • Thankyou for the replay,

    I done the same things..

    then also getting permission denied error while running the qt application..

    trying to login ssh root@192.168.7.2 there also same error permission denied..

    not getting what is the problem..


  • Lifetime Qt Champion

    @asha said in cannot run: no command:

    trying to login ssh root@192.168.7.2 there also same error permission denied..

    So, you actually can't login using SSH?
    Then you first need to solve this problem.
    Looks like root is not allowed to login via SSH on this device.
    Do you have other users there?
    Also, see https://www.cyberciti.biz/faq/howto-limit-what-users-can-log-onto-system-via-ssh/



  • yes I have other user as debian, through "ssh debian@192.168.7.2" I am able to login in target machine.


  • Lifetime Qt Champion

    @asha Then either use that user or enable root login via SSH



  • Hi,

    I login via debian user0_1568102197808_server.png

    then enabled the root login /etc/ssh/sshd_config file0_1568102251280_root.png

    here is the running status0_1568102281150_running.png

    now I am able login as a root0_1568102312397_rootlogin (1).png

    So, I changed the directory /opt permissions here "chmod go+wx opt"

    after this all, restarted the system ,and open the qt and run the simple application, the result is0_1568102663828_result.png

    0_1568102687165_result1.png

    So now what is the problem...any idea about this...(Thankyou very much)...


  • Lifetime Qt Champion

    @asha You did not cross compile your app for your device.
    You can verify this by doing (in a terminal):

    file PATH_TO_YOUR_EXE
    

    and checking its output.



  • can you give example,for more understanding purpose


  • Lifetime Qt Champion

    @asha You open a terminal and type "file" followed by the path to the executable file you built and press enter...
    For more information see "man file".



  • Hi,

    the result after typing "file /usr/lib/qt5/bin/qmake"0_1568112284524_exe.png



  • what it means,how to processed next.


  • Lifetime Qt Champion

    @asha Why qmake?
    It is about your app (beagle) which is created if you build your app.



  • 0_1568114786685_executable.png ,

    I build the application(beagle)but i dont no where exactly the location of executable.


Log in to reply