Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QWebEngine Install on Raspbian (Debian 10) Raspberry Pi 3 B+



  • Hi Everyone. That is my first post.

    I need to create one application which will run videos on the Raspberry Pi. When I try used QMediaPlayer then I run the videos the lack is terrible. When I run top command I see more of 100% of the CPU only for my process. Which is disaster.
    I also try with omxplayer. Is working but is not give me the functionality what I want. For example is not possible to stop the video and start again. I will use touch screen without keyboard.

    For that I decide to try with Create simple web page with only video tag and with simple javascript to manage start and stop of the video.
    But when I try to used it I see I don't have QWebEngine.

    I'm not make qt from source I just install libraries. But now I cannot found QWebEngine.
    What I install on raspbian is:

    sudo apt-get install pulseaudio
    sudo apt-get install cmake
    sudo apt-get install libvlccore-dev
    sudo apt-get install libvlc-dev
    sudo apt-get install qttools5-dev-tools
    sudo apt-get isntall qtdeclarative5-dev
    sudo apt-get install qtbase5-dev
    sudo apt-get install qtmultimedia5-dev
    sudo apt-get install qt5-qmake
    sudo apt-get install qt5-default
    sudo apt-get install qtmultimedia5-doc
    sudo apt-get install qtmultimedia5-doc-html
    sudo apt-get install qtmultimedia5-examples
    sudo apt-get install qml-module-qtquick-controls

    What library I need to install for can use QWebEngine.


  • Qt Champions 2019

    @evelikov92 Hi and welcome!
    On my Ubuntu (which is based on Debian just like Raspbian is) it is qtwebengine5-dev-tools



  • Hi @jsulm
    Is give me Unable to locate package qtwebengine5-dev-tools


  • Qt Champions 2019

    @evelikov92 What do you get if you execute

    apt search webview
    

    ?



  • @jsulm

    I reinstall the Raspbian and without install QT i get that result:
    libwxgtk-webview3.0-gtk3-0v5/stable 3.0.4+dfsg-8 armhf
    wxWidgets Cross-platform C++ GUI toolkit (GTK+ 3 webview library runtime)

    libwxgtk-webview3.0-gtk3-dev/stable 3.0.4+dfsg-8 armhf
    wxWidgets Cross-platform C++ GUI toolkit (GTK+ 3 webview library development)

    orthanc-webviewer/stable 2.5-1 armhf
    Web viewer of medical images for Orthanc

    python-wxgtk-webview3.0/stable 3.0.2.0+dfsg-8 armhf
    Python interface to the wxWidgets Cross-platform C++ GUI toolkit (wx.html2)

    python-wxgtk-webview4.0/stable 4.0.4+dfsg-2 armhf
    Python interface to the wxWidgets Cross-platform C++ GUI toolkit (wx.html2)

    python3-webview/stable 2.3+dfsg-1 all
    Build GUI for your Python program with JavaScript, HTML, and CSS

    python3-wxgtk-webview4.0/stable 4.0.4+dfsg-2 armhf
    Python 3 interface to the wxWidgets Cross-platform C++ GUI toolkit (wx.html2)

    qtwebview5-doc/stable 5.11.3-2 all
    display web content in a QML application - Documentation

    qtwebview5-doc-html/stable 5.11.3-2 all
    display web content in a QML application - HTML Documentation


  • Qt Champions 2019

    @evelikov92 Sorry, I mean

    apt search webengine
    


  • Sorting... Done
    Full Text Search... Done
    libqt5webchannel5/stable 5.11.3-2 armhf
    Web communication library for Qt

    libqt5webchannel5-dev/stable 5.11.3-2 armhf
    Web communication library for Qt - development files

    libqt5webengine-data/stable 5.11.3+dfsg-2 all
    Web content engine library for Qt - Data

    python-pyqt5.qtwebchannel/stable 5.11.3+dfsg-1+rpi1+b3 armhf
    Python 2 bindings for Qt5's WebChannel module

    python-pyqt5.qtwebchannel-dbg/stable 5.11.3+dfsg-1+rpi1+b3 armhf
    Python 2 bindings for Qt5's Webchannel module (debug extension)

    python3-pyqt5.qtwebchannel/stable 5.11.3+dfsg-1+rpi1+b3 armhf
    Python 3 bindings for Qt5's WebChannel module

    python3-pyqt5.qtwebchannel-dbg/stable 5.11.3+dfsg-1+rpi1+b3 armhf
    Python 3 bindings for Qt5's Webchannel module (debug extension)

    qml-module-qtwebchannel/stable 5.11.3-2 armhf
    Web communication library for Qt - QML module

    qtwebchannel5-doc/stable 5.11.3-2 all
    Web communication library for Qt - Documentation

    qtwebchannel5-doc-html/stable 5.11.3-2 all
    Web communication library for Qt - HTML Documentation

    qtwebchannel5-examples/stable 5.11.3-2 armhf
    Web communication library for Qt - Examples

    qtwebengine5-doc/stable 5.11.3+dfsg-2 all
    Qt 5 webengine documentation

    qtwebengine5-doc-html/stable 5.11.3+dfsg-2 all
    Qt 5 webengine HTML documentation

    qutebrowser/stable 1.6.1-2 all
    Keyboard-driven, vim-like browser based on PyQt5

    qutebrowser-qtwebengine/stable 1.6.1-2 all
    QtWebEngine backend dependency package for qutebrowser

    I think I understand, but not sure


  • Qt Champions 2019

    @evelikov92 Did you activate "universe" repository on your RaspberryPi?



  • @jsulm said in QWebEngine Install on Raspbian (Debian 10) Raspberry Pi 3 B+:

    "universe" repository on your RaspberryPi

    I think NO. Is fresh installation.
    How can I activate it?


  • Qt Champions 2019

    @evelikov92 Activate it, on Ubuntu many Qt webengine packages are in Universe



  • @jsulm

    root@raspberrypi:/home/pi# add-apt-repository universe
    Traceback (most recent call last):
    File "/usr/bin/add-apt-repository", line 95, in <module>
    sp = SoftwareProperties(options=options)
    File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in init
    self.reload_sourceslist()
    File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)
    File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in get_sources
    (self.id, self.codename))
    aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Raspbian/buster


  • Qt Champions 2019

    @evelikov92 Edit /etc/apt/sources.list



  • @jsulm

    What thing to add on the file?


  • Qt Champions 2019

    @evelikov92 Look for something like

    deb http://de.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
    

    Make sure universe is there



  • @jsulm Thanks for the help

    Get:1 http://de.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
    Hit:2 http://archive.raspberrypi.org/debian buster InRelease
    Err:1 http://de.archive.ubuntu.com/ubuntu bionic-backports InRelease
    The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    Hit:3 http://raspbian.raspberrypi.org/raspbian buster InRelease
    Reading package lists... Done
    W: GPG error: http://de.archive.ubuntu.com/ubuntu bionic-backports InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32
    E: The repository 'http://de.archive.ubuntu.com/ubuntu bionic-backports InRelease' is not signed.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

    I will leave it.
    I will install QT from the source. Maybe it will be faster.
    If is again not work then I will make the project in another way.


  • Qt Champions 2019

    @evelikov92 No! Don't add the line I posted to your /etc/apt/sources.list !
    It was just an example for how it looks.
    Search for a similar line in your /etc/apt/sources.list and make sure universe is there.



  • @jsulm Now I try to build from the source


Log in to reply