Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Building Qt Creator on macOS



  • Hi all,

    I'm having problems building qt creator on macOS (mojave). Here's the error.

    xcode-select: error: tool 'actool' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance
    make[2]: *** [/Users/jnkbd/devel/personal/build/src/app/asset_catalog_compiler.Info.plist] Error 1
    make[1]: *** [sub-app-make_first-ordered] Error 2
    make: *** [sub-src-make_first-ordered] Error 2
    

    ...and the full make output.

    https://pastebin.com/PNUqi0Bj


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Might be a silly question but do you have Xcode installed ?
    If so, which version ?



  • I have similiar issue and solve it with command: sudo xcode-select --reset



  • This is still happening.

    Just pulled and built Qt 5.15.0, then Qt Creator.

    make -j just failed with the error message reported here.

    I have Xcode 11.5 installed and working fine. I did xcode-select --reset as suggested above, but this induced a different error:

    /Library/Developer/CommandLineTools/usr/bin/clang++ -stdlib=libc++ -Wl,-rpath,@loader_path/../Frameworks,-rpath,@loader_path/../PlugIns -headerpad_max_install_names -arch x86_64 -isysroot /Library/Developer/CommandLineTools/SDKs/MacOSX.sdk -mmacosx-version-min=10.13 -Wl,-rpath,@executable_path/../Frameworks -Wl,-rpath,/usr/local/Qt-5.15.0/lib -o ../../bin/Qt\ Creator.app/Contents/MacOS/Qt\ Creator .obj/debug-shared/qtsingleapplication.o .obj/debug-shared/qtlocalpeer.o .obj/debug-shared/qtlockedfile.o .obj/debug-shared/qtlockedfile_unix.o .obj/debug-shared/main.o .obj/debug-shared/crashhandlersetup.o .obj/debug-shared/moc_qtsingleapplication.o .obj/debug-shared/moc_qtlocalpeer.o -F/usr/local/Qt-5.15.0/lib -L/Users/gavin/data/qt-creator-build/bin/Qt\ Creator.app/Contents/Frameworks -lExtensionSystem_debug -lAggregation_debug -lUtils_debug -framework CoreFoundation -framework QtWidgets -framework QtGui -framework AppKit -framework Metal -framework QtConcurrent -framework QtNetwork -framework QtCore -frameworkmake[2]: write error
    make[1]: *** [sub-app-make_first-ordered] Error 1
    make: *** [sub-src-make_first-ordered] Error 2

    Not sure what it's complaining about here, but doing sudo make worked.


  • Lifetime Qt Champion

    @Stokestack said in Building Qt Creator on macOS:

    write error

    Hi
    if it then worked with sudo , it just means that your current user didn't have write access to where it wanted to write.



  • @mrjj Indeed, thanks. But given that I was building to the default location, it seems that the documentation should make mention of the likely failure and potentially say to use sudo.


Log in to reply