Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Dependent (that clearly exists) does not exist error when building Qt Creator project



  • When I attempt to build a Qt Creator project I've inherited I get the following error:

    Error: dependent '..\..\..\GBusArtifact\Debug\interface\include\routercontroller\routercontroller_fw\router_app_service_interface.hpp' does not exist.
    jom: C:\Users\424997\Qt Projects\product_rapi_fromZip\Release_RP#2_3_1\projects\projects\build-product_rapi-Desktop_Qt_5_6_3_MSVC2015_64bit-Debug\Makefile [debug] Error 2
    16:22:11: The process "C:\Qt\Tools\QtCreator\bin\jom.exe" exited with code 2.
    Error while building/deploying project product_rapi (kit: Desktop Qt 5.6.3 MSVC2015 64bit)
    The kit Desktop Qt 5.6.3 MSVC2015 64bit has configuration issues which might be the root cause for this problem.
    When executing step "Make"
    

    Although that .hpp file clearly exists at the stated directory.

    I've tried:

    Running QMake (as suggested in a couple of answers to similar questions I found)
    Deleting my .pro.user file
    Changing Qt versions (the project seems to have been built with Qt 5.6.3, although changing to this made no difference)
    Shortening the file name (from application to app, including the two times it is included) in case the long directory was causing errors.

    Does anyone have any guesses on what could be the issue, I've been metaphorically banging my head against the wall all day.


  • Lifetime Qt Champion

    @jacobdbernard

    1. Close Creator
    2. Delete .pro.user and all Makefiles in the source directory
    3. Delete all build directories
    4. Move the project to a directory without spaces and special characters in its name
    5. Try again

    Regards



  • @aha_1980 Thanks for the idea but unfortunately it didn't work, I tried doing what you recommended at moved it to my desktop but I'm getting the same error. Unless you count underscores I don't believe there were any special characters in the path from /GBusArtifact/ onwards anyways, which is as far up as the path goes.


  • Lifetime Qt Champion

    @jacobdbernard

    C:\Users\424997\Qt Projects\product_800b_rapi_fromZip\800B_Release_RP#2_3_1\projects\projects\build-product_800b_rapi-Desktop_Qt_5_6_3_MSVC2015_64bit-Debug

    Not underscores, but the space in "Qt Projects" and the # could make problems.

    If that all doesn't help, you would need to show your .pro file (or upload the full code so we could try to compile it).



  • @aha_1980 Ah gotcha sorry, I was looking at the wrong line, with it on my desktop the error there is:

    jom: C:\Users\424997\Desktop\product_rapi_fromZip\800B_Release_RP2_3_1\projects\projects\build-product_rapi-Desktop_Qt_5_6_3_MSVC2015_64bit-Debug\Makefile [debug] Error 2
    

    My .pro file looks like this:

    TEMPLATE = app
    
    QT += qml quick widgets
    
    CONFIG += c++14 object_parallel_to_source
    
    # Main
    SOURCES += main.cpp
    HEADERS += main.h
    RESOURCES += qml.qrc
    
    qnx {
    MOC_DIR     = ./moc/
    OBJECTS_DIR = ./obj/
    RCC_DIR     = ./rcc/
    }
    
    #FORMS += \
    #    ../../pcsim/PCSimForm.ui
    
    CONFIG(release, debug|release): DEFINES += QT_NO_DEBUG_OUTPUT
    
    # Additional import path used to resolve QML modules in Qt Creator's code model
    QML_IMPORT_PATH =
    
    # Default rules for deployment.
    include(deployment.pri)
    
    # Component include
    include(../../common/common_adsevent/common_adsevent.pri)
    
    # Additional include
    include(../../dmhg.pri)
    include(../../dmhg_widget.pri)
    include(../../dmhg_behavior.pri)
    include(../../dmhg_app.pri)
    include(../../sdt.pri)
    include(../../common/common.pri)
    include(../../gbusinputter/gbusinputter.pri)
    include(../../guiinputter.pri)
    
    # ADS
    include(../../pcsim.pri)
    
    # Test
    include (../../test/test.pri)
    include (../../vehicle/vehicle.pri)
    
    # Additional
    INCLUDEPATH += \
        $$PWD/../../../GBusArtifact/Debug/interface/include \
        $$PWD/../../../GBusArtifact/Debug/interface/include/arbitrator \
        $$PWD/../../../GBusArtifact/Debug/interface/include/arbitrator/rba \
        $$PWD/../../../GBusArtifact/Debug/interface/include/arbitrator/rba/include \
        $$PWD/../../../GBusArtifact/Debug/interface/include/arbitrator/rba/include/model \
        $$PWD/../../../GBusArtifact/Debug/interface/include/arbitrator/rba/include/rba \
        $$PWD/../../../GBusArtifact/Debug/interface/include/arbitrator/rba/src \
        $$PWD/../../../GBusArtifact/Debug/interface/include/gbus_data \
        $$PWD/../../../GBusArtifact/Debug/interface/include/gfx_common_library \
        $$PWD/../../../GBusArtifact/Debug/interface/include/gfx_gbus_proxy \
        $$PWD/../../../GBusArtifact/Debug/interface/include/meter \
        $$PWD/../../../GBusArtifact/Debug/interface/include/rc \
        $$PWD/../../../GBusArtifact/Debug/interface/include/rc/application \
        $$PWD/../../../GBusArtifact/Debug/interface/include/rc/NOISEMETER \
        $$PWD/../../../GBusArtifact/Debug/interface/include/rc/NOISEMETER/template-gen \
        $$PWD/../../../GBusArtifact/Debug/interface/include/rc/NOISEMETER/template-gen/JSON \
        $$PWD/../../../GBusArtifact/Debug/interface/include/routercontroller \
        $$PWD/../../../GBusArtifact/Debug/interface/include/routercontroller/routercontroller_fw \
        $$PWD/../../../GBusArtifact/Debug/interface/include/routercontroller/stub_windowrouter \
        $$PWD/../../../GBusArtifact/Debug/interface/include/routercontroller/stub_windowrouter/reactor \
        $$PWD/../../../GBusArtifact/Debug/interface/include/routercontroller/stub_windowrouter/router \
        $$PWD/../../../GBusArtifact/Debug/interface/include/routercontroller/stub_windowrouter/router/query \
        $$PWD/../../../GBusArtifact/Debug/interface/include/routercontroller/stub_windowrouter/router/service \
        $$PWD/../../../GBusArtifact/Debug/interface/include/routercontroller/stub_windowrouter/utility
    
    CONFIG(release, debug|release): LIBS += \
        -L$$PWD/../../../GBusArtifact/Release/stalib/lib -lGBusClientLib -lroutercontroller -llibGCL
    else:CONFIG(debug, debug|release): LIBS += \
        -L$$PWD/../../../GBusArtifact/Debug/stalib/lib -lGBusClientLib -lroutercontroller -llibGCL
    

    Thanks a ton for helping me figure this out.


  • Lifetime Qt Champion

    @jacobdbernard

    Uhm... seems to be a bigger one. You will need to search the .pri files for router_app_service_interface.hpp and see if that gives you new insight.

    Resolving that might be a challenging task - not sure if forum support is sufficient for that.

    Regards



  • @aha_1980 That makes sense - I'll look into it, and for the record the antivirus/admin windows settings on my laptop are fairly strict because of company policies, any chance that could be causing issues?


  • Lifetime Qt Champion

    @jacobdbernard said in Dependent (that clearly exists) does not exist error when building Qt Creator project:

    and for the record the antivirus/admin windows settings on my laptop are fairly strict because of company policies, any chance that could be causing issues?

    Yeah, these are always a source for fun. However, in your case I doubt it.

    What you can also do is to inspect the generated Makefile. We already know it is wrong, but maybe you see why it is wrong.

    Good luck!


  • Lifetime Qt Champion

    Hi,

    @jacobdbernard said in Dependent (that clearly exists) does not exist error when building Qt Creator project:

    object_parallel_to_source

    I wonder if this one might be part of the problem.



  • @SGaist I see what you mean looking at the documentation, but unfortunately removing that option didn't seem to make a difference.



  • I have the same exact error on Windows 10 with Qt 5.12.3, but not on macOS 10.14.4 with same Qt version. I did not get this error on Windows 10 with Qt 5.5.1.

    I tried all the ideas above so this seems to be a bug in Qt 5.12.3 for Windows. Have you found any solution?


  • Lifetime Qt Champion

    @Cosmin124

    Do you use object_parallel_to_source ?



  • @aha_1980 No, I don't.


  • Lifetime Qt Champion

    @Cosmin124 It will be hard to help you without the actual project. At least all project files are needed.

    If you want to investigate yourself, check the compile output. sometimes builds fail just because of timing, i.e. dependency is build parallel or after the project that uses the dependency.

    Regards



  • Unfortunately I wasn't able to fix it @Cosmin124



  • Are other files from the same directory being included from this dir?

    $$PWD/../../../GBusArtifact/Debug/interface/include/routercontroller/routercontroller_fw \
    

    Have you tried doing an explicit include:

    HEADERS += <absolute path>
    or
    HEADERS += <relative path>
    

    Are there symbolic links in the path that could be screwing stuff up?



  • this might help:
    add the following to .pro file

    QMAKE_PROJECT_DEPTH = 0
    

    this will make all Makefile includes to absolute paths



  • @saurabhjadhav1911 Add QMAKE_PROJECT_DEPTH = 0 to .pro file works for me, thanks very much.


Log in to reply