Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Problem when creating or running C++ files on Qt



  • Hi everyone,

    I am fairly new with Qt and C++. I am trying to create and read projects Non-Qt, plain C++ projects on the Qt but the program gives me always this error:

    Executable C:\Users\Gonzalo Andalucia\Desktop"file name"\debug"file name".exe does not exist.

    where "file name" is the name of the file I have created or tried to read from a different PC.

    At the moment I am just trying to run the standar "hello world!" program from Qt but it simply does not allow me to do so. I have a Windows 10 laptop. In this post I also give you a full screenshot of the problem. Thank you for the help in advance.

    0_1550867462484_Qt Error.png



  • Hi,

    I have managed to solve the problem at the end. For some reason, Qt requires me first to build the project (click the hammer icon on the bottom-left corner or ctrl+B) and then run the file to be able to execute it. I have to build the project every time I make a change to the file or otherwise the console window does not display it and the new file is saved but when run, it executes the previous build. However, I will start saving my projects in a file path without spaces just in case. Thank you both SGaist and aha_1980 for your help.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    First surprising thing, you are not using the shadow build feature ?
    Second thing, do you have an anti-virus running ? Some of them don't like executable file creation and put them into quarantine before you can even execute them.

    One last thing to check, try again but put your project in a folder without spaces in the path.



  • Hi SGaist,

    Thank you for your reply. I have shadow build disabled for all my projects, I have no antivirus running when using Qt and I can not put my project in a folder without spaces since that is my User name. Even today I have tried creating a new project and I still have the same problem.


  • Lifetime Qt Champion

    @jefazo92

    I can not put my project in a folder without spaces

    That has caused lot's of troubles for many people before you. Just create a folder C:\Projects and use that. You won't get happy otherwise.

    Regards



  • Hi,

    I have managed to solve the problem at the end. For some reason, Qt requires me first to build the project (click the hammer icon on the bottom-left corner or ctrl+B) and then run the file to be able to execute it. I have to build the project every time I make a change to the file or otherwise the console window does not display it and the new file is saved but when run, it executes the previous build. However, I will start saving my projects in a file path without spaces just in case. Thank you both SGaist and aha_1980 for your help.


Log in to reply