Important: Please read the Qt Code of Conduct -

beginner error trying to deploy project

  • HI-

    _ZNSt18condition_variable4waitERSt1unique_lockStmutexE could not be located in the dynamic link library path QT5Core.dll.

    I am trying to run the pushbutton sample code and loaded the deployment files into the release directory of my project. I read one persons comment on google and they said you may not have linked to pthread but it is linking to mthread. Not sure where to even begin with this one. It finishes qmake and builds without errors with make. I am using most recent version of qt 5.11 and windows with mingw.

    This is my first partial night of using qt. thx. for any help! - roo_

  • I fixed it. It was not picking up the right files. I threw in everything but the kitchen sink and it worked. So I need to use the trick someone showed me on the web to select out the right files that I actually need. THX. Have a cool night. roo_

    "I also forgot to mention I tried to use windeployqt. I am reading where I might have the wrong deployment files and the right source and header files. I will look at that in a bit."


  • Moderators

    @roo_ said in beginner error trying to deploy project:

    _ZNSt18condition_variable4waitERSt1unique_lockStmutexE could not be located in the dynamic link library path QT5Core.dll.

    Often, this means you accidentally deployed the MSVC version instead of the MinGW version of Qt5Core.dll.

    The recommended way to deploy is to use windeployqt.

    If you want to deploy manually, make sure you copy the correct DLLs (do not take any DLLs from the Qt Creator folder!) See for details.

Log in to reply