Important: Please read the Qt Code of Conduct -

'Platform SDK installed' red X Adding Android SDK Tools in Qt Creator

  • Hi all!

    I am trying to get my Qt environment set up for android dev. I've included the sdk and ndk paths. Everything in the checklist (pictured below) is looking good except for the 'Platform SDK installed' which has a red x next to it. Does anyone know what might be causing this?
    0_1525121590955_Screen Shot 2018-04-30 at 4.43.37 PM.png
    Additionally, whenever I include the path for the location of the Android SDK, Qt prompts me with the following:
    0_1525121655192_Screen Shot 2018-04-30 at 4.54.05 PM.png
    But when I click 'yes' nothing happens. I assume these two issues go hand in hand. I don't want to start developing only to realize that something is all messed up because I didn't link up my android environment with my qt environment properly from the get go.

    Thanks all!

  • Lifetime Qt Champion


    What version of Qt are you using ?
    On what version of macOS ?

    Did you install the SDK/NDK prior to Qt Creator ?

  • Im using Qt 5.10
    on High Sierra version 10.13.4

    I had installed the SDK prior to installing Qt Creator, I installed the NDK after installing Qt Creator

    0_1525186040536_Screen Shot 2018-05-01 at 10.31.41 AM.png

  • Qt Champions 2016

    @abanksdev which version of QtCreator are you using ?
    I'm using 4.5.1 and this versions makes it very easy to manage Android SDK and Tools

  • Moderators

    I actually run into this a couple of days ago,

    the problem for me was, I had prio to everything RAD Studio installed, that came with its own SDK and NDK packages.

    Later I installed the newes SDK and NDK manually in a specific folder and hat the same issue setting up android kits in QtCreator

    The solution was to link against the previous installation of sdk, the one from RAD Studio, et voliĆ , every thing works as intended.

    So, you should check for prior installations of android sdk, for example through Android studio.

  • @J.Hilk That might be it, I'll try it. Does that mean that I can't have Android Studio installed and Qt linked up for Android dev? I use both programs

  • @ekkescorner I use Qt Creator 4.6.0

  • @J-Hilk what do you mean by 'link against?'

  • Moderators

    No, it's totoaly fine to have Android Studio on your pc as well. What I mean is.

    If you have installed Android Studio, that installs automatically Android SDK, if you than go and download the standalone Android SDK packet and install that as well.
    This was the situation I had. and "linking" aka passing the path to the original SDK installation in QtCreator 0_1525321257833_de124aa7-6a22-4e79-b330-69e001b92d54-image.png
    solved the issue for me.

  • @J-Hilk okay so basically what you're saying is that I should also install the standalone Android SDK and link to that rather than the SDK that comes with Android Studio?


  • @abanksdev no, I understand @J-Hilk says the other way around:

    passing the path to the original SDK installation in QtCreator

    setting Qt to use the Android SDK installed automatically by Android Studio (see the paths highlighted in previous post)

  • @J-Hilk @Pablo-J-Rogina I've already done that, I'm currently linking to the SDK installed automatically by Android Studio and that's what's causing issues. I don't have any other SDK installed at this time.

  • @abanksdev Ok, re-reading your post I now think what you're missing is SDK tools for a particular API level. See here the example about installing the SDK tools for API level 26:

    sdkmanager "platforms;android-26"

  • @Pablo-J-Rogina I have Android SDK Platform-Tools version 27.1.10, are you saying I should downgrade to 26?

  • @abanksdev No. What I said is that you need to check (and eventually install) the platform SDK you have installed, a component which is different from the platform tools.
    Could you please do:

    $ANDROID_HOME/tools/bin/sdkmanager --list

    and look at the top entries under "Installed packages: "

  • Hi all, it turns out that my JDK was incompatible with my Qt Version...I fixed the issue by deinstalling JDK 10 and installing JDK 8
    I am using the following Qt versions:

    0_1525568650970_Screen Shot 2018-05-05 at 9.03.55 PM.png

    With Qt Creator version 4.6.0

    And the sdk and ndk I am linking to are packaged within Android Studio (although I did have to download and install the ndk separately.)

  • @abanksdev great! so if your issue is solved, please don't forget to mark your post as such. Thanks.

  • I put in "--verbose" under Tools>Options>Devices>SDK Manager>Advanced Options and the red cross on platform SDK went away.
    0_1545261153164_860ebc3c-1456-46dd-9dbc-d57e6e101d16-image.png 0_1545261162111_ad141927-4b66-4df1-ac29-ea993afe2f20-image.png

  • @owflayar what if you try Androdi sdk-manager from command line? See my previous responses

  • Hi all,

    I met such problem and I could summarise how to fix it.

    1. "platform sdk not installed" in Manage Kits->Device.
    2. can't select Android build SDK in Active Project Build Setting for arm target.


    1. Install java8 and point the JDK location to it instead of java9 or java10
    2. as @Winning points out the link:

    There are issues with the updated Android SDK which makes it impossible to use it together with earlier versions of Qt for Android. This has been fixed in Qt 5.9.0, but for older versions, it is possible to use the following links to download a working version of the SDK (do not update the SDK after downloading): macOS Windows and Linux.

    Download tools_r25.2.5 and replace your SDK tools. Although my Qt is 5.12.0, this replacement is still required so the fix seems not in Qt 5.9.0 or later.

    Now all works well :)

  • Dear All,

    I was facing the same issue and I resolved by changing JDK,NDK and SDK. I have tried with JDK 12, NDK r19c and SDK 26.
    JDK 12 had version issues, NDK r19c had toolchain issues and SDK 26 had platform SDK issues.

    Finally, i fixed the environment by using below configuration:
    JDK 8, NDK r18b, SDK 25.2.5.

    I am using kit: Android for armeabi-v7a (Clang Qt 5.12.2 for Android ARMv7).

    @ajee I followed the step as you mentioned "Download tools_r25.2.5 and replace your SDK tools." It worked. Thank you.

    Please overwrite all files while copying into tools folder. Don't skip files.

    @abanksdev Please mark the topic resolved.


  • I had this exact problem on ubuntu 19.04 using QtCreator 4.8.2, Qt5.12.1 and setting the JDK path to an openjdk-12 directory that I downloaded and extracted to amy own directory. I tried setting the path to openjdk-11 which is installed already on my machine already in the default location on ubuntu (/usr/lib/jvm/java-xx-openjdk-xxx), and when the problem persisted, following the advice here, I installed openjdk-8 via apt package manager, it was installed to the dafault localtion (/usr/lib/jvm/java-xx-openjdk-xxx) and now the it has stopped complaining (regarding the platform SDK installed error). Thanks guys for the help, before finding this page I was messing around with SDK installations for ages as it is not at all obvious that the JDK is at fault here.

    To summarise for quick viewing:

    • trying to use openjdk 11 (and 12?) also causes this error
    • openjdk12 was not installed in the default ubuntu location when I tried it, and a default install openjdk 11 was present, so it's possible jdk12 might actually work of 11 wasn't present
    • using openjdk 8 fixed the issue as others have found

  • Would an update to stating that you must use openjdk-8 be appropriate? Or is the issue more complicated than a "one size fits all" approach? And is it possible for non Qt staff to submit updates to the docs for approval? I'll happily do it myself if so

  • This post is deleted!

  • Hi, I have some troubles with Qt for android too. Here is my qt android settings:

    And error that I get:

    I use kit: "Android for armeabi-v7a (Clang Qt 5.12.4 for Android ARMv7)"

    Can anybody help me please? :(

  • Hm, it's kinda weird, but I made android apk.
    So what I've done:
    I founded that I use build-tools ver. 29.0.0 but should use 28.0.3
    I didn't realize how to downgrade it so I just replace one file (aidl.exe) from 28.0.3 to 29.0.0 and it works.
    Now I able to build android apk.
    If someone need I could share my Qt android pacl

  • I had to uninstall jdk12 and install 8 for it to work. Is QT not compatible with 12? If not, there should be an indication of this when installing--that is indicate which versions of Java it is compatible with.

  • 138/5000
    I solved this problem by installing on QT5.13 earlier versions of NDK 20, from version 10e to 19c, this error no longer appeared.

  • @abanksdev thanks! For me it also works only with openjdk 1.8 (Java 8). I have openSUSE, Qt Creator 4.10, Qt 5.13.1.

  • @meisterpeeps seems Android Studio does not work well with jdk 12 as well: sdkmanager crashes.

  • Configuring QT 5.13 with Platform SDK installed error . I also have Android Studio 3.5 installed . Go to the settings of the Studio paths and copy them, JDK Android Studio puts its own, enter everything as it is in QT. The error disappears, QT starts to see all Studio and AVD tools. In the folder .android\ "empty" repositories.cfg " file. For successful compilation , in qmake add QMAKE_LINK + = - nostdlib++

  • 2019-10-24_09-40-37.png

  • Yesterday i faced the same issue. The only thing i did is that i downloaded "Java SE Development Kit 8 - jdk1.8.0_241" then both the errors regarding the Platform SDK and SDK manager worked properly.

  • Banned

    This post is deleted!

  • I hit this problem yesterday on Qt Creator 4.11.1. I finally did what @ajee did, but slightly different. I went to the qt-creator github and found this file: In it, you can find

    "sdk_tools_url": {
            "linux": "",

    I downloaded that zip file and copied over the tools dir like @ajee. I can't find that file in release 4.1.1 . Presumably, for future releases, that file may give you a clue as to which SDK tools you're supposed to download for your release of qt creator.

    P.S. What a pain.

  • Also, I would love it if the Qt team would specify the exact versions of Qt Creator, Android SDK, and Android NDK they're using.

  • @Ross +1 for the @ajee solution.

    I have been trying with Ubuntu 18.04 + OpenJDK 8 + Android Studio 3.6.3 + Qt Creator 4.11.2 / Qt 5.14.2 all downloaded and installed today, and could never get rid of the SDK tools or Platform SDK red Xs in Creator's Devices/Android form until adding the tools folder from your link - I placed it in my ~/Android/Sdk folder, next to the cmdline-tools and platform-tools folders, there was no tools folder there before, no matter what I tried to get Android Studio or sdkmanager to install.

    As soon as Qt Creator noticed the tools folder, now AVD manager and SDK manager tabs at the bottom of the Devices page are accessible. Here's hoping the rest of the porting process goes smoother.

Log in to reply