Unable to debug C/C++ - GDB complains about Python version



  • Hello, I'm trying to get started with QTCreator as my IDE for C/C++, and I ran into an issue, in that I get the following message whenever I try to debug my program: "The selected build of GDB supports Python scripting, but the used version 0.0 is not sufficient for QtCreator. Supported versions are Python 2.7 and 3.x"

    Which is rather strange, because if I run python --version, I get 3.6.4, and python2 --version is 2.7.14. GDB version is 8.1. I should probably mention that I'm running QTCreator 4.6.0, but the issue was present also in 4.5.2. OS is Manjaro, if that helps..
    I'm guessing the problem is on my end, somehow, but I can't seem to figue out how to fix it.


  • Qt Champions 2017

    Hi @Bioan,

    I have the strange feeling that your GDB is simply to new :(

    Can you please post the debugger log (Window > Views > Debugger Log) to check against?

    For me, the relevant part looks like this:

    &"show version\n"
    >~"GNU gdb (Ubuntu 7.11.1-0ubuntu1~16.5) 7.11.1\n"
    >~"Copyright (C) 2016 Free Software Foundation, Inc.\n"
    >~"License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>\nThis is free software: you are free to change and redistribute it.\nThere is NO WARRANTY, to the extent permitted by law.  Type \"show copying\"\nand \"show warranty\" for details.\n"
    >~"This GDB was configured as \"x86_64-linux-gnu\".\nType \"show configuration\" for configuration details."
    >~"\nFor bug reporting instructions, please see:\n"
    >~"<http://www.gnu.org/software/gdb/bugs/>.\n"
    >~"Find the GDB manual and other documentation resources online at:\n<http://www.gnu.org/software/gdb/documentation/>.\n"
    >~"For help, type \"help\".\n"
    >~"Type \"apropos word\" to search for commands related to \"word\".\n"
    >1^done
    dPARSING VERSION: 1^done
    dSUPPORTED GDB VERSION GNU gdb (Ubuntu 7.11.1-0ubuntu1~16.5) 7.11.1
    

    Regards



  • Hello aha, thank you for the reply.
    I've been able to get it running earlier this morning by manually specifying the kit, rather than relying on the auto-detected one. It's very strange, because it seems that it's the same selection.. GCC/GDB, and yet, when I manually select them, and create my own profile, it works.

    I do have a newer gdb (8.1), indeed, but that doesn't seem to be the issue. I'm guessing there's some sort of configuration problem on my machine. I'm going to keep digging and see if I can find what caused it, though.

    But first, I'll take Qt for a spin, and see why people say it's so good!


  • Qt Champions 2017

    @Bioan,

    glad you got it working. So please mark this topic as SOLVED.

    Regards


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.