Problem with QT webengine hardware acceleration



  • Hi guys, I had used qt and webengine in my project. but i found my web run slowly. i had checked my config with 'chrome://gpu', the hardware acceleration was not enable by default. my version is qt5.9.0.
    how i can enable the hardware acceleration?
    thanks.
    0_1502709881563_20170814192223.png



  • I had resolved this problem by reading the webengine resources and understanding the usefulness of chromium command line switches. The solution is as follows:
    1.I had finded that the QT resources(Src\qtwebengine\src\core\web_engine_context.cpp) have such a section as following picture shows:
    0_1503887223712_1.png
    This section is used to transmit the chromium command line switches into chromium browser progress .

    2.With the foundation of step one, i used these command lines such as "--ignore-gpu-blacklist" ,"--enable-gpu-rasterization" to my application. Then it works for me!
    0_1503900636579_2.png

    For your all reference.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.