"fatal: Needed a single revision" - init-repository not working



  • Hi,
    I was trying to clone the qt repository from https://github.com/qt/qt5.
    But I get the following error. I already deleted the directory two times and tried it again. Still the same error.

    I don't if this is relevant but on my first try I switched to the dev branch and then started the init-repository script. That gave me a similar error and I read somewhere that it's important to run the script first. May git cached something somewhere? I'm no good with git so I have no idea. Especially since it's been called from script.

    + git clone --no-checkout https://github.com/qt/qtlocation-mapboxgl.git src/3rdparty/mapbox-gl-native
    Cloning into 'src/3rdparty/mapbox-gl-native'...
    remote: Counting objects: 150328, done.
    remote: Compressing objects: 100% (588/588), done.
    remote: Total 150328 (delta 759), reused 982 (delta 633), pack-reused 149033
    Receiving objects: 100% (150328/150328), 154.35 MiB | 1.33 MiB/s, done.
    Resolving deltas: 100% (103293/103293), done.
    + git config remote.gerrit.url ssh://codereview.qt-project.org/qt/qtlocation-mapboxgl.git
    + git config remote.gerrit.fetch +refs/heads/*:refs/remotes/gerrit/* /heads/
    + git submodule update --force --no-fetch
    fatal: Needed a single revision
    Unable to find current revision in submodule path 'src/3rdparty/mapbox-gl-native'
    git submodule update --force --no-fetch exited with status 256 at ./init-repository line 198.
    	Qt::InitRepository::exe('Qt::InitRepository=HASH(0x7fa1e0803ff0)', 'git', 'submodule', 'update', '--force', '--no-fetch') called at ./init-repository line 429
    	Qt::InitRepository::git_clone_all_submodules('Qt::InitRepository=HASH(0x7fa1e0803ff0)', 'qtlocation.git', 0, 'all') called at ./init-repository line 435
    	Qt::InitRepository::git_clone_all_submodules('Qt::InitRepository=HASH(0x7fa1e0803ff0)', 'qt5', 0, 'preview', 'essential', 'addon', 'deprecated') called at ./init-repository line 644
    	Qt::InitRepository::run('Qt::InitRepository=HASH(0x7fa1e0803ff0)') called at ./init-repository line 655
    

    Thanks for any help!


  • Moderators

    Please follow this guide.

    Most notably, clone from official repo. Init-repository may be expecting that.

    git clone git://code.qt.io/qt/qt5.git
    


  • Thanks, that helped.
    I was able to compile qt from source now.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.