Problem creating QT Widgets Application



  • I just wanted to try out Qt for a desktop application today, but when creating a QT Widgets Application, the second step labeled "Kits" gave me the error: No valid kits found.
    I went to Tools -> Options -> Build and Run -> Kits, which had a kit named "Desktop (Default)." I set up the compiler properly, but the Qt version option only had two options: "None" and "Qt 5.9.1 for Android armv 7." This is how my window looks:

    alt text

    I used the offline installer from the Qt mirror download page. The file is named: qt-opensource-windows-x86-5.9.1.exe

    EDIT: I tried the offline installer again and it seems to have some other components that were not selected. Looks like this:

    alt text

    If anyone could tell me which ones to choose, that would be great.

    EDIT2: I'm just stupid. I installed all the kits that looked desktop related to me (MSVC20xx and MingW), and it worked.

    Thank you.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.