having problem deploying Qt Xlsx



  • hello I am having problem deploying my qt application. I am using Qt Xlsx from the github repo [https://github.com/VSRonin/QtXlsxWriter](link url) to manipulate xlsx files. My program works perfectly when running it in Qt Creator, but upon deploying my app (specifically just by clicking the .exe file in the build release folder) and even using qtwindeploy, the application is unable to perform Xlsx functions. I followed this procedure [https://wiki.qt.io/Deploy_an_Application_on_Windows](link url) and it still doesn't work. Even using Usage(1) or Usage(2) from the site, it still doesn't work.
    Deployment folder image https://drive.google.com/open?id=0B0QHvTmZsWa6bEItSjVyN0dpSVE. I am using Qt 5.4.2 and am using windows 10.



  • Did you deploy Qt5Xlsx.dll?



  • what do you mean deploy? If you meant a deployed application the yes, using windeployqt. From the first method (Usage 1) of QtXlsx, I used qmake to install it into the default Qt modules, then went to the build release folder of the project, open the terminal there, then typed: windeployqt .
    the result would be a deployed application, including the Qt5Xlsx.dll. As for the Qt5Xlsxd.dll, there was no file in the deployed app, only the Qt5Xlsx.dll. Even if I copied Qt5Xlsxd.dll to the deployed folder, it still wouldn't work.



  • VRonin does it work when you deploy yours with windeployqt?



  • What error are you getting?



  • the app is a release version. I don't know how to get the error messages outside qt other than the qt console. the app does not crashed, it just does not write into the excel file. It just skips the xlsx lines and executes the next valid line.



  • ok it was a path misunderstanding. somehow the debug version of xlsx when running qt is located outside the release folder, while when in deployed mode the default location is inside the release folder. you might want to fix this bug. also path directories should not have spaces. works perfectly though thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.