WebEngine OpenGL implementation is not supported



  • All,
    After much aggravation, I have built QtWebEngine and QtWebView. I need to display static html pages and believe QtWebView is the way to do that - it works on my dev machine. BUT on the Raspberry Pi target, I get a continuous stream of errors when attempting to open an html file. I have build with qmake configured for EGLFS as I do not intend to use Xwindows. The error I get is:

     1295 tty1     00:00:00 QtWebEngineProc     
    :ERROR:gl_surface_qt.cpp(661)] Requested OpenGL implementation is not supported. Implementation: 
    

    I have tried all the GL drivers available in raspi-config (something like full KMS, Fake KMS and legacy no GL). My Qt app fails to run under any of the KMS selections and runs with Legacy but give above mentioned webView error. I installed libgli_mesa_dri on the RPi.

    Can anyone help?

    Thanks



  • Hello,

    Have you found the solution ?
    I have the same prob, in log:

    ERROR:surface_factory_qt.cpp(68)] Failed to load =/opt/vc/lib/libEGL.so.1: =/opt/vc/lib/libEGL.so.1: cannot open shared object file: No such file or directory
    [:ERROR:gl_surface_qt.cpp(661)] Requested OpenGL implementation is not supported. Implementation: 0
    ... infinite same error until crash...

    File exist:
    file libEGL.so.1
    ELF 32-bit LSB shared object, ARM, EABI5 version 1 (SYSV), dynamically linked
    file myapp
    ELF 32-bit LSB executable, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 3.2.0

    so myapp can't load lib

    I use Qt with linux-rpi-3 device, with armv8 config, but on my pi3: lscpu give Architecture: armv7l (32bit OS), all libs are built with armv7l, I will try to build qtbase with linux-rpi-2 instead 3.



  • Hi,

    I have crossbuild QtWebEngine 5.9.1 with rpi2 (armv7l) instead rpi3 (armv8) target and libEGL is loaded, webengine widget work without the error.

    I have some other libs built with armv8 and they are loaded. I don't understand why libEGL and libGLES have the issue.



  • Using https://github.com/Kukkimonsuta/rpi-buildqt/issues/12 I got the same error. I got it to work though by tricking my app with a quick symlink
    ln -s / =
    Qtwebengine is now loading and showing pages, however mouse interaction is not working at all, which makes it useless for me! Keyboard navigation (TAB, SPACE, RET) is working, so it really should only be a minor issue or setting, which I may be overlooking.
    Did you have success with qtwebengine?


  • Moderators

    Check if it is not the issue mentioned in point 11 of this wiki.



  • Thank you for your response! However I had done that already.
    I am really curious, why I do not have any mouse interaction. Otherwise everything looks good. On html5test.com I get 507 points.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.