opengl test failed when configure qt asource



  • Re: [I built Qt Everywhere for beaglebone black (OS Debian) but fail](somebody used to built it success can help me?)
    I meet the same problem when i try to build qt on alpine.

     OpenGL:
        EGL .................................. no
        Desktop OpenGL ....................... no
        OpenGL ES 2.0 ........................ no
        OpenGL ES 3.0 ........................ no
        OpenGL ES 3.1 ........................ no
      Session Management ..................... yes
    Features used by QPA backends:
      evdev .................................. no
      libinput ............................... no
      mtdev .................................. no
      tslib .................................. no
      xkbcommon-evdev ........................ no
    QPA backends:
      DirectFB ............................... no
      EGLFS .................................. no
      LinuxFB ................................ no
      Mir client ............................. no
    Qt Widgets:
      GTK+ ................................... no
      Styles ................................. Fusion Windows
    Qt PrintSupport:
      CUPS ................................... no
    
    WARNING: No QPA platform plugin enabled! This will
    produce a Qt that cannot run GUI applications.
    The dependencies needed for xcb to build are listed in
    src/plugins/platforms/xcb/README
    
    ERROR: The OpenGL functionality tests failed!
    You might need to modify the include and library search paths by editing QMAKE_INCDIR_OPENGL[_ES2],
    QMAKE_LIBDIR_OPENGL[_ES2] and QMAKE_LIBS_OPENGL[_ES2] in the mkspec for your platform.
    
    Check config.log for details.
    
    4282eca8c0a9:~/qtbase-opensource-src-5.8.0# QMAKE_INCDIR_OPENGLYou might need to modify the include and library search p
    aths by editing QMAKE_INCDIR_OPENGL[_ES2], QMAKE_LIBDIR_OPENGL[_ES2] and QMAKE_LIBS_OPENGL[_ES2] in the mkspec for your
    platform.
    

    I find there is no change when i edit the mkspec of my platform, then i specify my platform manually by add param
    "-platform linux-g++-64" then the problem solved.



  • @wegatron This means you don't have an opengl installed on your BB or in your sysroot. Or you passed incorrect parameters to your ./configure.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.