Activating QML debugging ignored



  • Hello,

    I'm using Qt Creator 4.2.1 on Linux 64bit. In my Qt 5.4.0 project I enabled the Qml Debug support project/build/qmake settings and also under project/run/debugger settings

    Sometime ago it was working for me but I'm not able to enable Qml Debugging. When starting the debug session the debugger log view gaves me the following information that Qml debugging settings are ignored. But it did not tell me why:

    "QDeclarativeDebugServer: Ignoring "-qmljsdebugger=port:43357,block,services:DebugMessages,QmlDebugger,V8Debugger,QmlInspector". Debugging has not been enabled."

    A view with netstat shows me that port 43357 is not opened.

    Any idea why it's ignroed and how to enable the Qml debugging?

    Thanks & best regards Michael



  • I checked the source and it seems that my Qt libraries are compiled without qml debug option enabled

        if (!QQmlEnginePrivate::qml_debugging_enabled) {
            qWarning() << QString(QLatin1String(
                              "QML Debugger: Ignoring \"-qmljsdebugger=%1\". "
                              "Debugging has not been enabled.")).arg(
                              appD->qmljsDebugArgumentsString());
            return;
        }

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.