Adding QtWebEngine after initial Qt5.8 build: plug-in not installed



  • Hi all,

    I've carefully followed https://wiki.qt.io/Building_Qt_5_from_Git
    During the init-repo I've skipped WebEngine since I had compilation errors.
    Went through the developer-build configuration, and got a working Qt5.8.1
    Also compiled QtCreator4.2, added the previously built Qt5.8.1 within a kit.
    Everything worked smoothly.

    Now I need qtwebengine so i tried to build it following https://wiki.qt.io/How_to_Try_QtWebEngine
    I git clone in the same qt5 directory to avoid confusions.
    I used the Qt5.8.1 previously built qt5/qtbase/bin/make
    I had problems, but finally got make qtwebengine successful

    Now here is my problem: when adding import QtWebEngine 1.4 (or whatever version) to any project, I got a "not installed" error. Looked at the qt5/qtbase/include and can't see any QtWebEngine dir
    Also tried sudo make install within qt5/qtwebengine but it didn't change anything
    Same problem when building QtWebKit I also skipped during Qt5.8.1 initial build.

    So what's happening? How to link the fresh built QtWebEngine to my QtCreator / Qt environment?
    Shall I rather try to go back to the first stage and build Qt5.8.1 from ground with QtWebEngine?
    For reference I'm under some ARM64 environment without available cross compilation solution, so building is really long (approx 6-8 hours for the a Qt5.8.1 build without QtWeb stuff ...).

    Any help would be much appreciated...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.