QtCreator4.0.2 can't setup qbs and build profile



  • Hi, I am running Ubuntu 16.04, QT 5.7.0 with QtCreator 4.0.2, cmake 3.5.1, arm-gcc-embedded 6.2.1.
    I have tried to setup an embedded environment (IDE and toolchain) for the nrf51822 SoC, according to this post: http://morf.lv/starting-with-nrf51-ble-and-qt-creator ... the QtCreator stuff starts below the movie.
    I have setup a new kit for nrf51822,compiler,debugger, screen shots attached. For some reason it doesn't seem to work, the Build and Run buttons are greyed out.

    0_1487619737517_upload-57c15046-7ff8-45f4-8bb8-dd3c45941359
    0_1487619773340_upload-0ec5d4a1-f97c-448a-9af5-19850c89e7e3
    0_1487619844217_upload-2f5e8d9c-6249-4b6a-b5f2-45596f403c62
    0_1487620109774_upload-7a8f5434-3473-4b8c-8590-ce4336c5a707
    The same profile that is highlighted above (qtc_nRF51822_e68e6805) appears under the Qbs settings as well, below
    0_1487620327769_upload-b25da462-3e69-41fa-9a09-c26eecced466
    I don't know where this profile came from, it was obviously named by QtCreator and I can't seem to change it.
    I have tried to set up qbs profiles manually using the qbs setup-toolchains --type gcc /usr/bin/arm-none-eabi-g++ newprofile command after installing the arm-gcc-embedded 6.2.1.
    Please ignore the nRF51 profile, that I have created for the old gcc-arm-none-eabi-4_9-2015q2, which I have uninstalled.
    0_1487620654039_upload-04211a89-aab9-45c2-9972-ce30e36ab9d0
    While it shows that this profile was created, I cannot set it as default. I have tried in the Qbs settings window which I have found in ~/Qt5.7.0/Tools/QtCreator/bin by running qbs-config-ui (which I believe should be qbs-config-gui), but it didn't make a differece. After a few trials the e68e6805 profile appeared here, so I have tried to make it default, but to no avail.0_1487621484492_upload-7f2a1412-d0c1-47c3-a245-68924137ea88
    0_1487621614390_upload-38fea8ef-549a-4048-a38d-c4f139f086ba
    then I have tried to make the arm-gcc the default profile, but with the same resolution
    0_1487621768544_upload-cd75df10-09b2-4c41-ad16-840ba12d6a81
    Many searches later and I came across this file Qt5.7.0/Tools/QtCreator/share/qtcreator/QtProject/qtcreator/profiles.xml shown below (which I don't think has anything to do with my problem, but maybe, maybe, can be a part of the solution?
    0_1487622015417_upload-0ac71274-b01b-4609-be1f-129189891f10

    I've been spending about 2 weeks trying to figure this on my own (for the sake of learning by myself), but it seems I can't do it. Please help, I don't know what I'm missing here... or maybe it's a bug... any help/suggestions greately appreciated... If any of you has successfully done such a setup please point me in the right direction before I get a stroke.

    Thanks!


  • Moderators

    @Mircea Please note that attaching pictures usually does not work in this forum. You need to upload them to somewhere and post links here.



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.