QtWebEngine "Uncaught NotSupported Error: Failed to executed" on "MediaSource"



  • I'm trying to build a QtWebEngine in Qt5.6.2 clang 2 panel that opens a HTML5 Media Player, so I setup my page and run it locally, and the video renders fine in various browsers.

    I than build the various examples based on QtWebEngine (which should be based on Chromium).

    When I open my page, the player starts, but no video is displayed and the application output starts throwing errors?

    js: Uncaught NotSupportedError: Failed to execute 'addSourceBuffer' on 'MediaSource': The type provided ('video/mp4; codecs="avc1.42E01E, mp4a.40.2"') is unsupported.
    

    Any ideas on how I should compile this to display my video in this player?

    Update:

    I have now found that I should be compiling with the flags:

    WEBENGINE_CONFIG+=use_proprietary_codecs
    

    I tried adding this to my qmake command in QtCreator, but this doesn't not seem to have any effect

    qmake /Users/jordanbaucke/Qt/Examples/Qt-5.6/webengine/minimal/minimal.pro -spec macx-clang CONFIG+=debug CONFIG+=x86_64 CONFIG+=qml_debug WEBENGINE_CONFIG+=use_proprietary_codecs && /usr/bin/make qmake_all
    

    I've decided to checkout QtWebKit (branch 5.6), and build from source. With the appropriate flags. If it is functional, how do I ensure that the necessary flags are compiled into when I use QtWebKit in other projects?

    Update 2

    Still no luck! I built the afromentioned QtWebKit library from source and attempted to run the demos...unfortunately they had the same result?!

    ~/Documents/workspace/qtwebengine$ ~/Qt/5.6/clang_64/bin/qmake WEBENGINE_CONFIG+=use_proprietary_codecs
    Info: creating cache file /Users/jordanbaucke/Documents/workspace/qtwebengine/.qmake.cache
    Running configure tests
    Checking for khr... no
    Checking for snappy... no
    Checking for srtp... no
    Proprietary codecs (H264, MP3).... Enabled
    Geolocation....................... Enabled
    

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.