Does Chromium/Chrome need to be installed on linux in order to use QtWebEngine?



  • I've been getting my a** kicked trying to figure out the dependencies to using QtWebEngine in my Qml based application and deploying it to a linux box without Qt installed.

    I finally got it to the point where I could hide the Qt folder on my dev box (CentOS 7 x64 vm), start the application from a single folder on the desktop, and everything worked great. This box has Chrome installed already.

    I tried just dumping this self-contained folder onto a clean Ubuntu x64 vm and a clean CentOS 7 x64 vm.

    The Ubuntu vm just hung for a long period of time (as in several minutes) and then suddenly my application appeared. I thought this might be a one time caching issue, but everytime I start it on Ubuntu it takes a crazy amount of time to do anything - there's no CPU usage, and the HDD isn't in use. When it does startup, and I go to the UI that hosts the WebEngineView - the view comes up fine, but when I navigate anywhere it immediately core dumps. Looking at the core dump with gdb wasn't particularly helpful (I just looked at the backtrace and it crashes in QtWebEngine) so before I started really looking into that I moved to try the clean CentOS vm. The other Qml based UIs in the application appear to function just fine once it starts up.

    When I start it on the CentOS image - it starts up instantly and all the other UI views work fine (Qml based but not using WebEngineView.) When I select the UI with the WebEngineView it comes up as expected, and then when I navigate it core dumps - but I see an error in the console first: "js: Uncaught InvalidAccessError: Failed to execute 'measure' on 'Performance': 'responseEnd' is empty: either the event hasn't happened yet, or it would provide cross-origin timing information."

    Anyhow - has anyone successfully deployed a Qt Qml application that uses WebEngineView to a linux box that doesn't have Qt installed?

    Also, as an aside, how are developers supposed to know that you have to package things like "qtwebengine_devtools_resources.pak" (and other pak files) with the QtWebEngineProcess?



  • Nope. Installing Chrome and its dependencies didn't affect anything (not that I really expected it to.)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.