Qt4.8 and tslib



  • Hello

    My problem is similar to this
    I want to compile Qt4.8 for ARM-system with tslib support
    I got tslib , successfuly configured it with

    sudo ./configure --host=arm-none-linux-gnueabi --prefix=/home/zaleski/dev/cpp/tslib-arm --enable-static --enable-shared
    

    then sudo make && sudo make install
    After it I made the copy of /path_to_qt4.8.6_sources/mkspecs/qws/linux-arm-gnueabi-g++ to /path_to_qt4.8.6_sources/mkspecs/qws/linux-arm-gnueabi-g++myboard and added to qmake.conf

    QMAKE_INCDIR += /home/zaleski/dev/cpp/tslib-arm/include
    QMAKE_LIBDIR += /home/zaleski/dev/cpp/tslib-arm/lib
    QMAKE_LFLAGS += -lts
    

    But when I made

    sudo ./configure -opensource -confirm-license -prefix /home/zaleski/dev/cpp/qt/qt4.8.6-arm-tslib -embedded arm -xplatform qws/linux-arm-gnueabi-g++myboard -optimized-qmake -nomake tools -nomake examples -nomake demos -qt-mouse-tslib -qt-mouse-linuxinput -qt-kbd-linuxinput -qt-gfx-linuxfb -qt-zlib -force-pkg-config -qt-mouse-qvfb -qt-kbd-qvfb -qt-gfx-qvfb -webkit -no-cups -no-largefile -openssl -openssl-linked -no-mmx -no-sse -no-sse2 -no-qt3support -no-nis -v -no-dbus -L /home/zaleski/dev/cpp/tslib-arm/lib -I /home/zaleski/dev/cpp/tslib-arm/include
    

    such error has occured:

    tslib auto-detection... ()
    arm-none-linux-gnueabi-g++ -march=armv5te -mfpu=neon -mfloat-abi=softfp -mfpu=vfpv3-d16 -O0 -c -pipe -O2 -Wall -W  -I../../../mkspecs/qws/linux-arm-gnueabi-g++myboard -I. -I/home/zaleski/dev/cpp/tslib-arm/include -I/home/zaleski/dev/cpp/tslib-arm/include -o tslib.o tslib.cpp
    make: arm-none-linux-gnueabi-g++: Command not found
    Makefile:181: recipe for target 'tslib.o' failed
    make: *** [tslib.o] Error 127
    tslib disabled.
    The tslib functionality test failed!
     You might need to modify the include and library search paths by editing
     QMAKE_INCDIR and QMAKE_LIBDIR in
     /home/zaleski/dev/cpp/sources/qt-everywhere-opensource-src-4.8.6/mkspecs/qws/linux-arm-gnueabi-g++myboard.
    

    How can I correctly configure the qt?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Where do you have arm-none-linux-gnueabi-g++ located on your system ?



  • @SGaist said:

    Where do you have arm-none-linux-gnueabi-g++ located on your system ?

    arm-none-linux-gnueabi-g++ is in /opt/codesourcery/bin
    This path is added to $PATH environment variable in ~/.profile


  • Lifetime Qt Champion

    Can you call it from the command line where you are trying to cross-compile Qt ?



  • Thanks a lot
    I added full path to arm-none-linux-gnueabi-g++ to qmake.conf

    QMAKE_CC                = /opt/codesourcery/bin/arm-none-linux-gnueabi-gcc -march=armv5te -mfpu=neon -mfloat-abi=softfp -mfpu=vfpv3-d16 -O0
    QMAKE_CXX               = /opt/codesourcery/bin/arm-none-linux-gnueabi-g++ -march=armv5te -mfpu=neon -mfloat-abi=softfp -mfpu=vfpv3-d16 -O0
    QMAKE_LINK              = /opt/codesourcery/bin/arm-none-linux-gnueabi-g++ -march=armv5te -mfpu=neon -mfloat-abi=softfp -mfpu=vfpv3-d16 -O0
    QMAKE_LINK_SHLIB        = /opt/codesourcery/bin/arm-none-linux-gnueabi-g++ -march=armv5te -mfpu=neon -mfloat-abi=softfp -mfpu=vfpv3-d16 -O0
    

    and it solved the problem


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.