Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

How to get QT Creator to use CDB instead of GDB?



  • I am trying to debug my application. However immediately upon attempting to debug the application, I am receiving a warning:
    "<Filepath>":not in executable format: File format not recognized.

    I read somewhere that it means CDB isn't installed and setup correctly since I'm using Windows. So I installed it and Qt Creator was able to find it automatically, however I still have GDB installed from something else. When i open the 'Debugger Log' view, it appears that it is still attempting to use GDB. Is there a way to force it to use CDB instead? Do you think that's my problem?

    Thank you!



  • Finally figured it out by myself, in case anyone else has this same issue:

    Got to Tools->Options->Build & Run -> Kits

    Select the 'Kit' that you want and change the debugger in the form that pops up.


Log in to reply