Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtCreator over VNC. Windows client, linux server.



  • Has anyone been able to run QtCreator over a VNC connection to a linux server? I am running Debian "Jessie" and have tried both vnc4server and tightvncserver for the VNC server. I am using TIghtVNC Viewer on a WIndows (both 7 and 10) client. I have tried both LXDE and xfce4 for the VNC desktop (I couldn't get Gnome to work at all).

    If I try to start QtCreator from the menu nothing happens. If I start it from a terminal I get the following messages:

    Qt: XKEYBOARD extension not present on the x server.
    Could not initialize GLX

    Thanks in advance for any help anyone can provide.



  • Hi, I am running Debian "Wheezy" on a Linode headless server, and I used to have the same problem starting Qt Creator (with vnc4server).
    But i found TigerVNC and that seems to work (I have version 1.1.0).



  • @hskoglund Thanks for the tip. How did you install TigerVNC? Did you build from source? It is not available in the standard repositories for Debian "Jessie". I do see that TigerVNC has a pre-built .deb package for Ubuntu14.04LTS, but I wasn't sure if that would install clean or not. I also found a repository here , but I am not familiar with it so I am a little hesitant to use it. Thanks again.



  • Just looked at my server, the package was called tigervnc-server but I installed it October 2013. can't remember where I got it, sorry.
    But I looked at that repository tigervnc-standalone-server, seems harmless enough.. what could go wrong?

    Edit:
    just tested Qt Creator 3.5.1 (Qt 5.5.1) on the server:
    editing, compiling and running a widgets app works fine (you can type into a textbox etc.), but I notice that I do get the same 1st line you get "Qt: XKEYBOARD extension not present on the X server." But I do not get the "Could not initialize GLX" and the app runs ok.

    However, when I tried a QML demo app (Planets) I only get an empty white window, and a 2nd line: "WARNING: Application calling GLX 1.3 function "glXCreatePbuffer: when GLX 1.3 is not supported..."
    So it seems even tigervnc-server has its limitations :-(



  • @hskoglund I tried installing from the repository that I linked to, but it failed with unmet dependencies. I haven't been able to resolve that. I started looking into building it, but it looks a bit complicated. Maybe when I have some time I will attempt it. Thanks again for your help.



  • I ended up using NX instead of VNC to get QtCreator to work. This also allows me to use Gnome 3 desktop, which I could never get to work with VNC. For anyone else who may be interested, the Linux packages can be downloaded HERE and a Windows client can be downloaded HERE. Scroll down to the NoMachine Enterprise Client section for standalone client installers.



  • Good news, and thanks for the links. I think I'll be testing that NX stuff soon...


Log in to reply