[Solved] Qt.labs.particles...



  • Has anyone tried using the QML demos/examples in the Nokia Qt SDK beta? There's a closed bug mentioning a problem with Mac packaging for Qt in general where qt.labs.particles is missing, but I'm finding exactly the same thing in Windows with the latest version downloaded from Forum Nokia.



  • Has this solved itself in the meantime or should I investigate a bit on the matter?



  • I updated my Nokia Qt SDK today and it is still not resolved. This is the error I get when trying to start a new game in SameGame:
    @error loading block component
    file:///C:/NokiaQtSDK/Demos/4.7/declarative/samegame/SamegameCore/BoomBlock.qml:2 module "Qt.labs.particles" is not installed@

    Similar errors in all other examples/demos that use the particles module - I can make them work by commenting out the use of particles - but it would be nice to have this labs module in the SDK if it's going to be used in the examples! :)


  • Moderators

    Please file issues like this in the <a href="http://bugreports.qt.nokia.com/">bugtracker</a>, using the Nokia Qt SDK project.

    All of us check the bugtracker several times a day while most do not participate in the beta test of this site.



  • The same problem came up again with Qt 4.7.2 on Kubuntu natty. To fix it an additional package needs to be installed.
    libqt4-declarative-particles


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.