Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[solved] Weird Qt behaviour - selecting and deleting code



    • When selecting code and press delete nothing happens; just the code is getting unselcted and the last letter is getting deleted.
    • When selecting code and typing, say the letter 'k', it appears after the selected code instead of deleting the selection and replace it by 'k'.
    • When trying to select text by pressing Shift+Arrow_keys just the cursor moves but no selection.
      Sometimes it seems that the cursor appears like a block (like in insert mode and it changes its behaviour when pressing insert, but not at all to what I expect).
    • Ctrl+c or Ctrl+v is not working either.
    • When using mouse selection and using the arrow keys after I am able to increase/decrease the selection. In this case it seems like that Qt creator changes to a kind of insert-mode.

    This is a fresh Qt Creator 3.3 installation (from Software Center) on an Ubuntu 15.04 machine. I installed it (same configuration) on another PC but there I have none of these problems.

    I hope you can help me an I am in the right section for my post.

    Thanks.


  • Moderators

    Hi and welcome.

    Sounds like you entered the "FakeVim" mode somehow. Go to Tools -> Options -> FakeVim and see if the "Use FakeVim" checkbox is selected. If so - deselect it.



  • @Chris-Kawa Thanks, that seemed easier than expected. Maybe I will find out one day why Vim is still existing. ;)



  • @holzkohlengrill
    that's easy: because some people like it. now you know.



  • @Chris-Kawa Oh my goodness.s. thanks so much.. I was so frustrated with copy and paste, I couldn't use the "shift+ arrow key to select and every time my cursor is changing while block and I have to press the "insert" key to get back to normal cursor. thanks so much .. you saved me ..



  • But WHY?

    I love to use vim, but I hate that selecting does not work. And usually with all software that supports vim, selecting via shift + move works fine. Can I disable this somehow?


  • Lifetime Qt Champion

    @IceMichael

    Hi.
    I have not seen any option for fakevim saying "use normal selection" so
    i dont think so.

    alt text