Qt Creator doesn't recognize PATH-variable on Mac OSX



  • After building Qt on my 32 Bit Mac for the last four hours, I did "sudo qmake install".
    I also changed the the PATH-variable in .profile according to this tutorial http://doc.qt.nokia.com/4.7-snapshot/install-mac.html

    When I do "echo PATH" in a bash it returns:

    @/usr/local/Trolltech/Qt-4.7.3/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/X11/bin
    @

    Qt Creator still doesn't recognize it in Settings -> Qt4.

    I'm also too dumb to add the SDK in the list on my own (can't jump to that folder in the Finder and can't input it directly).

    Please help me out!



  • If your PATH is modified in .bashrc or the like, then this change is not visible to Qt Creator if you start it from the Finder!

    It is visible, if you start it on a bash terminal with

    @
    open /Applications/Qt\ Creator.app
    @

    You can modify the environment in Qt Creator on the project pane at build and/or run settings. Or you can add the PATH to your global environment by adding an entry to a ~/.MacOSX/environment.plist file. See Apple's docs on "Environment Variables":http://developer.apple.com/library/mac/documentation/MacOSX/Conceptual/BPRuntimeConfig/Articles/EnvironmentVars.html



  • Thanks, it works now.

    Sadly I encountered another problem.
    I can compile and run the examples shipping with the SDK, but when I open my own project (which comes from Windows) a window pops up saying

    bq. No valid Qt-versions could be found.
    Please add a valid version at extras/settings or by using the sdk-installation-utility.
    (I freely translated this text).

    For some reasons I can't change any setting at all (all of them are greyed out). All I can do is close the project.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.