QOpenGLWidget using OpenGL ES only when deployed, otherwise, using OpenGL desktop

  • Hello,

    I am facing strange problems with my Qt application that I ported from Qt 5.1 to Qt 5.5 on Windows. I initially posted this question, but now that the problem is more specific, I am posting in a new thread. I hope this is ok.

    So in short: I am using old OpenGL code (i.e. glBegin(), etc.) inside of a Qt5.5 application. When I start the application from QtCreator, it works without problem and the QOpenGLWidget's context is telling me that it is not using OpenGL ES (when testing this with openglWidget->context()->isOpenGLES() ). So my old openGL code is running fine via QtCreator launch.

    When deployed however, the QOpenGLWidget's context is telling me that it is using OpenGL ES. So my old openGl code is not running fine and I experience crashes.

    I feel the answer to my problem is very simple, but I can't put my finger on it. I tried many approaches (by correctly deploying with windeployqt.exe, also trying to specify --no-angle), etc., but nothing helped. I am at a loss here.

    My project file contains (running on Windows 8):

    QT += network opengl widgets
    LIBS += -lopengl32

    I tried with:


    but then nothing works anymore, when launched via QtCreator, or the deployed application.

    What else can I try?

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.