Qt Static build, issue with QtCreator (related to ABI detection)



  • Hi ,
    I just tried my first installation test of Qt Static. (I am porting current .NET project to Qt+Qml).
    what I did was Qt Static under MinGW with OpenSSL but

    When I added the Qt static to Qtcreator , it reported ABI detection failed !!!!
    I did an other compilation with Older release as described in => "How to build a static Qt version for Windows with GCC":http://developer.qt.nokia.com/wiki/How_to_build_a_static_Qt_version_for_Windows_with_gcc

    I compiled QtCreator latest from Gitorious , when I opened the Qt Creator from CMD (Command Prompt) , i saw this error message that is the reason that ABI was unable to be detected by the Qt version.

    C:\QtSDK\Desktop\Qt\4.8\creator\bin>qtcreator.exe
    Warning: Could not find ABI for 'c:/qtsdk/desktop/qt/4.7.4/mingw-static/mkspecs/
    win32-g++' ('Qt 4.7.4 for Desktop - MinGW 4.4 static', c:/qtsdk/desktop/qt/4.7.
    4/mingw-static/bin/qmake.exe)/g++ by looking at C:/QtSDK/Desktop/Qt/4.7.4/mingw-
    static/lib/libQtCore.a:Qt Creator does not know about the system includes, nor t
    he system defines.

    it does not look like a bug in QtCreator , it is my mistake...
    this is my configuration steps :
    Qt 4.7.4 (downloaded by Git from qt.gitorious.org from branch/4.7)
    copied to c:/qtsdk/desktop/qt/4.7.4/mingw-static (where also I have shared version installed successfully in a different directory called 4.7.4/mingw )
    PATH=> %QTDIR%=c:/qtsdk/desktop/qt/4.7.4/mingw-static
    set QMAKESPEC=win32-g++
    set MINGW=C:\MinGW
    set OPENSSL=C:\OpenSSL
    set INCLUDE=%OPENSSL%\include;%MINGW%\include
    set LIB=%OPENSSL%\lib;%MINGW%\lib
    set PATH=%QTDIR%\bin;%OPENSSL%\bin;%MINGW%\bin;%PATH%

    .... and so on based on the page i mentioned.

    Need help thanks in advance.
    ( )


  • Moderators

    Is there a file called C:/QtSDK/Desktop/Qt/4.7.4/mingw-static/lib/libQtCore.a? If so, can you please mail it to me (via profile page)?

    Maybe my ABI detection goes astray.



  • Already sent , thanks for help dear tobias



  • I got at least a working copy of Static build based on 4.7.4 on MSVC2008 with following CONFIG:
    @set QTDIR=.....
    set QMAKESPEC=win32-msvc2008
    set OPENSSL=C:\OpenSSL
    set INCLUDE=%OPENSSL%\include;%INCLUDE%
    set LIB=%OPENSSL%\lib;%LIB%
    set PATH=%QTDIR%\bin;%OPENSSL%\bin;%PATH%

    also , I changed CFLAGS
    @QMAKE_CFLAGS_RELEASE = -O1 -MT
    QMAKE_CFLAGS_DEBUG = -Zi -MTd@

    configure.exe -static -opensource -platform win32-msvc2008 -nomake examples -nomake demos
    ../jom/jom.exe -j 4@

    but new problem occurred. now the ABI is "x86-windows-unknown-pe-32bit" !!!!!!!!

    • where i made a mistake or what do you think ?*

    the system is unable to locate a correct toolchain... in Qt Creator



  • Thanks to "Tobias Hunger: for his solution as mentioned in the "Qt Reported Bug 4771":http://bugreports.qt.nokia.com/browse/QTCREATORBUG-4771

    just need to copy QtCore*.dll for now. thanks for his help and support


  • Moderators

    Satmosc: That is not a solution, that is a workaround:-)

    The solution is in Qt Creator's master branch now. I am trying to get that merged back into the Qt Creator 2.2 branch so it will be in 2.2.1 if we decide to release one.



  • @Tobias Hunger : you are right , I mean it , but I wrote ":solution" that is actually "Temproary solution" until a real solution.
    by the way , it helped me alot thank you again


  • Moderators

    Thank you for taking the time needed to do good bug reports and to follow up on them. Without that the issue would still be in creator.



  • Thank you very much. time is not important. as a Certified MS developer on .net platform , I found Qt much better platform than all I have used till now. it is fast and also if you get trouble , it is not like MS developer channels where you should wait for several months to year for a service pack (specially I had issue with Anti Aliasing in .NET that at last it came to play in XAML on .NET 4 platform where .NET was 4 times slower than same project with more effects on QML.(even if QML has a long road to go , but it works as expected much more better than XAML)....

    By the way , I still have problems , but I am sure it is because of my knowledge and it is great that we can get update or fix , or add our own ...


  • Moderators

    I split your new debugging helper issue of into "this thread":http://developer.qt.nokia.com/forums/viewthread/5724/ . It is a very different issue and I want the new issue to be more visible.

    Unfortunately the new topic is not really my area of expertise:-(



  • @Tobias :: I think we need to reopen QTCREATORBUG-4771 because the latest SDK 2.2 version and also GIT all branches again have same Issue again !!!!!!!!!!!!!!!!
    I remember you fixed it , I just updated my GIt version and I found that in new Git updates and all other branches again we have the same issue and we need to copy Core*.dll files to fix the issue.

    should I reopen the 4771 ? my current QtCreator is 2.2.81 (master from GIT)

    Thanks and kind Regards,


  • Moderators

    Feel free to open a new bug or reopen an existing one:-)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.